aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 11:24:14 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 11:24:26 +0000
commitec93ed40c08ae8af196fd752f8d998627dff182c (patch)
tree7c0441a886cebf5e9e496cf5dd9722eb9d027e68 /community
parentbeabbad99781714acd7bff0de8a16ac8ee242f15 (diff)
community/openjdk7: set correct _jarch on aarch64
Diffstat (limited to 'community')
-rw-r--r--community/openjdk7/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/community/openjdk7/APKBUILD b/community/openjdk7/APKBUILD
index b2fc312c69d..2e8e7ff714d 100644
--- a/community/openjdk7/APKBUILD
+++ b/community/openjdk7/APKBUILD
@@ -28,12 +28,13 @@ RHINO_VER=1.7.7.1
ANT_VER=1.9.7
case $CARCH in
-x86) _jarch=i386;;
-x86_64) _jarch=amd64;;
-arm*) _jarch=arm
- # openjdk has quite a bit of arm assembly producing textrels
- # and it's non trivial to fix. allow it for now.
- options="$options textrels";;
+x86) _jarch=i386;;
+x86_64) _jarch=amd64;;
+aarch64) _jarch=aarch64;;
+arm*) _jarch=arm
+ # openjdk has quite a bit of arm assembly producing textrels
+ # and it's non trivial to fix. allow it for now.
+ options="$options textrels";;
esac
INSTALL_BASE=/usr/lib/jvm/java-1.7-openjdk