aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJake Buchholz <tomalok@gmail.com>2019-07-02 01:21:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-07-02 11:21:48 +0200
commitfc9ba844edfcb935fa56b5d07852d35303a5c816 (patch)
treefeaaa08827fa1af7ea87b6e9e09f2832886abcd1 /community
parente38cc5c779adba34a5ac51a5d66fbf109094862a (diff)
community/runc: update to 1.0.0-rc8
Release notes at https://github.com/opencontainers/runc/releases/tag/v1.0.0-rc8
Diffstat (limited to 'community')
-rw-r--r--community/runc/APKBUILD33
1 files changed, 14 insertions, 19 deletions
diff --git a/community/runc/APKBUILD b/community/runc/APKBUILD
index ab3d9acad95..615c4808f00 100644
--- a/community/runc/APKBUILD
+++ b/community/runc/APKBUILD
@@ -2,43 +2,38 @@
# Maintainer: Jake Buchholz <tomalok@gmail.com>
pkgname=runc
-
-# NOTE: using explicit post-1.0.0_rc6 commit, for CVE-2019-5736
-# (https://nvd.nist.gov/vuln/detail/CVE-2019-5736). This commit is more recent
-# than the one specified by containerd
-# (https://github.com/containerd/containerd/blob/v1.2.2/vendor.conf)
-_commit=6635b4f0c6af3810594d2770f662f34ddc15b40d
-
-pkgver=1.0.0_rc6
-pkgrel=1
pkgdesc="CLI tool for spawning and running containers according to the OCI specification"
url="https://www.opencontainers.org"
+
+_commit=425e105d5a03fabd737a126ad93d62a9eeede87f
+pkgver=1.0.0_rc8
+pkgrel=0
+
+_ver=v${pkgver/_rc/-rc}
+# if we're building against an explicit commit beyond pkgver, use this instead:
+#_ver=${_commit}
+
arch="all"
license="Apache-2.0"
makedepends="go go-md2man libseccomp-dev libtool"
subpackages="$pkgname-doc"
-source="runc-$_commit.tar.gz::https://github.com/opencontainers/runc/archive/$_commit.tar.gz"
+source="runc-$_ver.tar.gz::https://github.com/opencontainers/runc/archive/$_ver.tar.gz"
builddir="$srcdir/src/github.com/opencontainers/runc"
# secfixes:
-# 1.0.0_rc6-r1:
+# 1.0.0_rc7:
# - CVE-2019-5736
build() {
cd "$srcdir"
export GOPATH="$PWD"
- mkdir -p $(dirname "$builddir")
- ln -s "$PWD/$pkgname-$_commit" "$builddir"
+ mkdir -p "$(dirname "$builddir")"
+ ln -s "$PWD/$pkgname-${_ver#v}" "$builddir"
cd "$builddir"
make COMMIT="$_commit"
make man
}
-check() {
- cd "$builddir"
- ./runc --version
-}
-
package() {
cd "$builddir"
install -Dsm755 "$builddir"/runc "$pkgdir"/usr/bin/runc
@@ -46,4 +41,4 @@ package() {
install -Dm644 "$builddir"/man/man8/* "$pkgdir"/usr/share/man/man8/
}
-sha512sums="37bb09463df4742b0ea5b1f079f609642ab5621707674844ffef06f733703ec1d09b52a180ccb2d66c284c56ba242f7a1b70ba4c4c45722bf85fd2fd924bb9df runc-6635b4f0c6af3810594d2770f662f34ddc15b40d.tar.gz"
+sha512sums="4bf464acc87b6d687010f0c070d96e171d91e46c45b84b5570c6f607e7d06777d2d83b2ead87ac4aa761e34afc68a3d9be9ab25107d499e8f41cb68647e23541 runc-v1.0.0-rc8.tar.gz"