summaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-12-05 15:10:50 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-12-05 15:11:41 +0100
commit35369524ae405311b08f4f901e9c95bc126d2309 (patch)
tree27090267e2ad4c6d1ff1efd6870617db4c0644bd /community
parent5cfedff629a942779e7c145abfb810b364cc7da6 (diff)
community/liboping: move from testing
Needed as dependency for collectd.
Diffstat (limited to 'community')
-rw-r--r--community/liboping/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/liboping/APKBUILD b/community/liboping/APKBUILD
new file mode 100644
index 00000000000..c628d5f0102
--- /dev/null
+++ b/community/liboping/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Harry
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=liboping
+pkgver=1.9.0
+pkgrel=0
+pkgdesc="A C library to generate ICMP echo requests"
+url="http://verplant.org/liboping/"
+arch="all"
+license="LGPL2+"
+depends=""
+makedepends="ncurses-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://verplant.org/liboping/files/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib \
+ --without-perl-bindings \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir" || return 1
+}
+
+md5sums="9c9f65bfd297d7e7092c7f219c31f66a liboping-1.9.0.tar.bz2"
+sha256sums="44bb1d88b56b88fda5533edb3aa005c69b3cd396f20453a157d7e31e536f3530 liboping-1.9.0.tar.bz2"
+sha512sums="dcbadeea5154d4f4c31f806cae4ee5b8d5a8dfe243a9de4dad4b81b5b227538e1bb0c20afef121bd8ad841346da39fd5fb4710db981b89c11acc573c4f401c85 liboping-1.9.0.tar.bz2"