aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-10-22 06:12:38 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-11-30 17:14:33 +0000
commit02e2fb8504ea6f19d5f086a033842588cf517275 (patch)
tree3010b98f86b4193cdb93e34360f42f2909ce7086 /community
parente161415b5cc6f8e504f5fa93e440df5a240ce699 (diff)
community/xf86-video-rendition: move from main
Diffstat (limited to 'community')
-rw-r--r--community/xf86-video-rendition/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/xf86-video-rendition/APKBUILD b/community/xf86-video-rendition/APKBUILD
new file mode 100644
index 00000000000..9900912b150
--- /dev/null
+++ b/community/xf86-video-rendition/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xf86-video-rendition
+pkgver=4.2.7
+pkgrel=0
+pkgdesc="Rendition video driver"
+url="https://xorg.freedesktop.org/"
+arch="all"
+license="MIT"
+subpackages="$pkgname-doc"
+depends=
+options="!strip"
+makedepends="xorg-server-dev libxi-dev util-macros xorgproto"
+source="https://www.x.org/releases/individual/driver/$pkgname-$pkgver.tar.bz2"
+
+builddir=$srcdir/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ export LDFLAGS="$LDFLAGS -Wl,-z,lazy"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+
+ # Stripping manually
+ strip $pkgdir/usr/lib/xorg/modules/drivers/rendition_drv.so
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+
+sha512sums="5a23a599488946499e9bb3dfaf553cd68b6a1555a9c46b4038f355038a28747715bb940c52170f909917386911c8ae2607c669ba28f24a6c10ad375dab4535aa xf86-video-rendition-4.2.7.tar.bz2"