aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-12-27 17:42:36 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-27 18:18:57 +0100
commit04020396dba0a02f569c658e74bb7551079e6ca1 (patch)
tree8f0cb3858c2904949aba11f42d91e00d18dd05ea /community
parent838eee50992f9e40a8a1301b475cb03edf40624e (diff)
community/ffmpegthumbs: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/ffmpegthumbs/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/ffmpegthumbs/APKBUILD b/community/ffmpegthumbs/APKBUILD
new file mode 100644
index 00000000000..eb664452992
--- /dev/null
+++ b/community/ffmpegthumbs/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=ffmpegthumbs
+pkgver=19.12.0
+pkgrel=0
+arch="all"
+url="https://www.kde.org/applications/multimedia/"
+pkgdesc="FFmpeg-based thumbnail creator for video files"
+license="GPL-2.0-or-later"
+makedepends="extra-cmake-modules qt5-qtbase-dev kio-dev ki18n-dev kconfig-dev ffmpeg-dev"
+source="https://download.kde.org/stable/release-service/$pkgver/src/ffmpegthumbs-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
+options="!check" # No tests
+
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
+build() {
+ cd "$builddir"/build
+ cmake "$builddir" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ cd "$builddir"/build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"/build
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="69db3a49d5596d5df30e6dd5a95e9f8bc3d18c2bd5aeac6bd89468338ef4b983af8e67b4c56875dd1cb7b9206c6803732e5151a74c116e6154486221247e9762 ffmpegthumbs-19.12.0.tar.xz"