aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-05-04 12:15:40 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-06 12:52:16 +0200
commit143b6dfe7e521eaa10d7a257087630092bf005fa (patch)
tree74069650c1498bfbace2be8927cb41c95b4d323c /community
parentcfbc29cf5515b9db19825e27c0be592b13b229a5 (diff)
community/zstd: move from testing and claim maintainership
Diffstat (limited to 'community')
-rw-r--r--community/zstd/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/community/zstd/APKBUILD b/community/zstd/APKBUILD
new file mode 100644
index 00000000000..efde85d3e24
--- /dev/null
+++ b/community/zstd/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: stef <l0ls0fo2i@ctrlc.hu>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=zstd
+pkgver=1.1.4
+pkgrel=0
+pkgdesc="Zstandard - Fast real-time compression algorithm"
+url="http://www.zstd.net"
+arch="all"
+license="BSD"
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/facebook/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make -j1
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
+}
+
+sha512sums="8d18635494a584d13ab29645af5f20b6c1d2fb72895854c381c783b6fda0950575632d04a72e6901ae178535d5f6319ab25fdb097ef8c6db559d60acf558a437 zstd-1.1.4.tar.gz"