aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-06-01 21:40:20 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-06-01 20:19:17 +0000
commit1ab8c592fd72208f9f0a3ac214d31f8d0c61bd4c (patch)
tree268c8aa72960cc6713d6fcbc5dbe459efa33fdad /community
parent1c2d6462c050ee87ab0562814b1d23fe37ece3d1 (diff)
community/xeyes: modernize
Diffstat (limited to 'community')
-rw-r--r--community/xeyes/APKBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/community/xeyes/APKBUILD b/community/xeyes/APKBUILD
index 81c3f3a7a90..1eb62484fb1 100644
--- a/community/xeyes/APKBUILD
+++ b/community/xeyes/APKBUILD
@@ -2,21 +2,17 @@
# Maintainer: ScrumpyJack <scrumpyjack@me.com>
pkgname=xeyes
pkgver=1.1.2
-pkgrel=0
+pkgrel=1
pkgdesc="A pair of eyes that follow your mouse in X11"
-url="http://www.x.org"
+url="https://www.x.org"
+options="!check" # no test suite
arch="all"
license="MIT"
-depends=""
-depends_dev=""
makedepends="libx11-dev libxt-dev libxext-dev libxmu-dev libxrender-dev"
-install=""
subpackages="$pkgname-doc"
-source="https://www.x.org/releases/individual/app/${pkgname}-${pkgver}.tar.bz2"
-builddir="$srcdir/$pkgname-$pkgver"
+source="https://www.x.org/releases/individual/app/xeyes-$pkgver.tar.bz2"
build() {
- cd "$builddir"
./configure \
--prefix=/usr \
--datarootdir=/usr/share
@@ -24,7 +20,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}