aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2022-01-28 15:25:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2022-01-28 15:25:56 +0000
commit27240c4af8950fbecb9107b0dfae7b6b6ad31bbd (patch)
treea200cdf9263bcb6a39dcdbd3112f0de4a1125f62 /community
parentd78ae3c00943dda907f1e2f48813e74350dfdcff (diff)
community/sg3_utils: upgrade to 1.47
upstream report: https://github.com/hreinecke/sg3_utils/issues/77
Diffstat (limited to 'community')
-rw-r--r--community/sg3_utils/APKBUILD10
-rw-r--r--community/sg3_utils/unsigned-int.patch15
2 files changed, 22 insertions, 3 deletions
diff --git a/community/sg3_utils/APKBUILD b/community/sg3_utils/APKBUILD
index 8250b83b028..dc5b240217c 100644
--- a/community/sg3_utils/APKBUILD
+++ b/community/sg3_utils/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sg3_utils
-pkgver=1.45
+pkgver=1.47
pkgrel=0
pkgdesc="Generic SCSI utilities"
url="http://sg.danny.cz/sg/sg3_utils.html"
@@ -10,7 +10,8 @@ options="!check" # No test suite.
license="BSD-2-Clause AND GPL-2.0-or-later"
makedepends="linux-headers"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://sg.danny.cz/sg/p/sg3_utils-$pkgver.tgz"
+source="http://sg.danny.cz/sg/p/sg3_utils-$pkgver.tgz
+ unsigned-int.patch"
build() {
./configure \
@@ -32,4 +33,7 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="e7a8d0bcee707fe8a3bbdb7b5579e48a9176b5968f3ebfb5b5c39c4b7d70b65c7e48f3b57580833b658354922d1d1aed28b177e669610f555d2aebc4b88d51d0 sg3_utils-1.45.tgz"
+sha512sums="
+27e43eb1103d6fb321af106964e56b800688ee74ebc47201cda1f29703ddaa34655cb0a6ce926952fdb66e10904e32dda4ca448789e9305a02d55f5477d5d21d sg3_utils-1.47.tgz
+e288986ef0cdb6a6a07fea51bbeb02f8071eb689eecab8f91c4a6a82528bbed865e1c7b76bc4a5d8236eff1d11e09214ad1d443704b32427d849e2af0cedbb23 unsigned-int.patch
+"
diff --git a/community/sg3_utils/unsigned-int.patch b/community/sg3_utils/unsigned-int.patch
new file mode 100644
index 00000000000..ca6d8111f07
--- /dev/null
+++ b/community/sg3_utils/unsigned-int.patch
@@ -0,0 +1,15 @@
+Upstream report: https://github.com/hreinecke/sg3_utils/issues/77
+
+diff --git a/src/sg_dd.c b/src/sg_dd.c
+index 9d05c93..7662728 100644
+--- a/src/sg_dd.c
++++ b/src/sg_dd.c
+@@ -2399,7 +2399,7 @@ main(int argc, char * argv[])
+ res = blocks * blk_sz;
+ if (iflag.zero && iflag.ff && (blk_sz >= 4)) {
+ uint32_t pos = (uint32_t)skip;
+- uint off;
++ unsigned int off;
+
+ for (k = 0, off = 0; k < blocks; ++k, off += blk_sz, ++pos) {
+ for (j = 0; j < (blk_sz - 3); j += 4)