aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorTaner Tas <taner76@gmail.com>2018-04-26 08:34:51 +0300
committerFrancesco Colista <fcolista@alpinelinux.org>2018-05-08 09:19:09 +0000
commit296647babb5e1798c6294d6620643265c1166d94 (patch)
tree58918f74e0217ae92dbe2797996f8b619ffcc94e /community
parentb9ab9bebf72c9cf1e98417708593e4986ef8991c (diff)
community/network-manager-applet: Upgrade to 1.8.6
* Add libgnome-keyring as dependency
Diffstat (limited to 'community')
-rw-r--r--community/network-manager-applet/APKBUILD20
-rw-r--r--community/network-manager-applet/fix-without-selinux.patch22
2 files changed, 9 insertions, 33 deletions
diff --git a/community/network-manager-applet/APKBUILD b/community/network-manager-applet/APKBUILD
index 850aee7d006..129a9ee0475 100644
--- a/community/network-manager-applet/APKBUILD
+++ b/community/network-manager-applet/APKBUILD
@@ -1,12 +1,12 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=network-manager-applet
-pkgver=1.7.1
-pkgrel=1
+pkgver=1.8.6
+pkgrel=0
pkgdesc="GTK network manager applet"
url="https://wiki.gnome.org/Projects/NetworkManager"
arch="all"
license="GPL"
-depends=""
+depends="libgnome-keyring"
depends_dev=""
makedepends="$depends_dev
gcr-dev
@@ -20,11 +20,10 @@ makedepends="$depends_dev
modemmanager-dev
networkmanager-dev
polkit-dev
+ libgnome-keyring-dev
"
-install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.gnome.org/sources/network-manager-applet/${pkgver%.*}/network-manager-applet-$pkgver.tar.xz
- fix-without-selinux.patch
"
builddir="$srcdir/network-manager-applet-$pkgver"
@@ -37,16 +36,15 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --without-selinux \
--with-gcr \
- || return 1
- make || return 1
+ --enable-static=no \
+ --without-selinux
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-sha512sums="d4b0cd5dcb219c34abf9c4f4df0861e3198c45edbb1e8d45eb53fe85fc590dd0486eb978c4445430554c70f337bb9e8fa9367c5c1689228ecc2c30194e8d7ff0 network-manager-applet-1.7.1.tar.xz
-ceff76ac33ddd54e0d1428a43cb6cdba177843de6355ab0119b9e54e766330dffa1e91a6a0857e749c76c728af808de45f79433316acf125d58579092a33c47e fix-without-selinux.patch"
+sha512sums="9080fe1ef252837f16c698fe2083ebe66949e2a30f626619ef7eb82f44e988a0b8488f4f8cd0946a78a240f9bf7a5d054afc988b25c1bedeba7f79a7c84d46fa network-manager-applet-1.8.6.tar.xz"
diff --git a/community/network-manager-applet/fix-without-selinux.patch b/community/network-manager-applet/fix-without-selinux.patch
deleted file mode 100644
index 0134cc0610a..00000000000
--- a/community/network-manager-applet/fix-without-selinux.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/src/connection-editor/nm-connection-editor.c b/src/connection-editor/nm-connection-editor.c
-index ca74d12..be211f2 100644
---- a/src/connection-editor/nm-connection-editor.c
-+++ b/src/connection-editor/nm-connection-editor.c
-@@ -31,7 +31,7 @@
- #include <errno.h>
- #include <gdk/gdkx.h>
-
--#ifdef WITH_SELINUX
-+#if WITH_SELINUX
- #include <selinux/selinux.h>
- #endif
-
-@@ -183,7 +183,7 @@ update_sensitivity (NMConnectionEditor *editor)
- }
- }
-
--#ifdef WITH_SELINUX
-+#if WITH_SELINUX
- /* This is what the files in ~/.cert would get. */
- static const char certcon[] = "unconfined_u:object_r:home_cert_t:s0";
-