aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2019-05-27 22:59:33 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2019-05-27 23:08:35 +0200
commit31ab57a781ed0fcb95cfd79ed64599f2bdc6c1bb (patch)
tree208042e2ec79fa6cf47059bff77938146d695228 /community
parenta4d7d06328f8af7cafd861fcb193f223ea16985d (diff)
community/firefox-esr: fix build with recent rust
Diffstat (limited to 'community')
-rw-r--r--community/firefox-esr/APKBUILD2
-rw-r--r--community/firefox-esr/fix-rust.patch26
2 files changed, 28 insertions, 0 deletions
diff --git a/community/firefox-esr/APKBUILD b/community/firefox-esr/APKBUILD
index 870ad858ac4..4e46f6ef0ee 100644
--- a/community/firefox-esr/APKBUILD
+++ b/community/firefox-esr/APKBUILD
@@ -52,6 +52,7 @@ makedepends="
source="https://ftp.mozilla.org/pub/firefox/releases/${pkgver}esr/source/firefox-"$pkgver"esr.source.tar.xz
stab.h
+ fix-rust.patch
fix-fortify-system-wrappers.patch
fix-fortify-inline.patch
disable-hunspell_hooks.patch
@@ -264,6 +265,7 @@ __EOF__
sha512sums="c2152857f5f1c816a12fcf5c450268025ee47ee9299ae3355650d86c7c97191b731123a4964154222ca5ba1edc44fee0d1d5f803ae9515841283ecaff6dc9a55 firefox-60.7.0esr.source.tar.xz
0b3f1e4b9fdc868e4738b5c81fd6c6128ce8885b260affcb9a65ff9d164d7232626ce1291aaea70132b3e3124f5e13fef4d39326b8e7173e362a823722a85127 stab.h
+845209a7f831c069a1c1d20f88e388423656f7c2f0915b5e7cfb7f47947883d4f9eb2f887b6f10ac5d75d0b323b495b693ec21cd2208ee5071283089bc023f07 fix-rust.patch
2f4f15974d52de4bb273b62a332d13620945d284bbc6fe6bd0a1f58ff7388443bc1d3bf9c82cc31a8527aad92b0cd3a1bc41d0af5e1800e0dcbd7033e58ffd71 fix-fortify-system-wrappers.patch
09bc32cf9ee81b9cc6bb58ddbc66e6cc5c344badff8de3435cde5848e5a451e0172153231db85c2385ff05b5d9c20760cb18e4138dfc99060a9e960de2befbd5 fix-fortify-inline.patch
0fcc647af53a3ce21c2bc36e5631eb0935e7243ebb3ab59b5719542cc54a6ac023a4a857b43b75756efb9ed80c0aecaa94dc5679a3b3792f82e87bf2c1af82e1 disable-hunspell_hooks.patch
diff --git a/community/firefox-esr/fix-rust.patch b/community/firefox-esr/fix-rust.patch
new file mode 100644
index 00000000000..d3e6546c102
--- /dev/null
+++ b/community/firefox-esr/fix-rust.patch
@@ -0,0 +1,26 @@
+This fixes build errors under recent Rust.
+
+Taken from void linux: https://github.com/void-linux/void-packages/commit/5fb88cfb0a16ceb873d41560ccd8fd863ced9279
+
+--- a/servo/components/style_traits/lib.rs
++++ b/servo/components/style_traits/lib.rs
+@@ -9,7 +9,7 @@
+ #![crate_name = "style_traits"]
+ #![crate_type = "rlib"]
+
+-#![deny(unsafe_code, missing_docs)]
++#![deny(unsafe_code)]
+
+ extern crate app_units;
+ #[macro_use] extern crate bitflags;
+--- a/servo/components/style/lib.rs
++++ b/servo/components/style/lib.rs
+@@ -23,8 +23,6 @@
+ //! [cssparser]: ../cssparser/index.html
+ //! [selectors]: ../selectors/index.html
+
+-#![deny(missing_docs)]
+-
+ extern crate app_units;
+ extern crate arrayvec;
+ extern crate atomic_refcell;