aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2019-05-13 13:24:38 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-14 04:44:55 +0000
commit40778576ea234488611ab788dc136011b693c775 (patch)
tree09fd1d0d5fd6dd56d40e6f243c9dbbbbaa279443 /community
parent90727a988e5735acd1a50b0d6d1346958595d0d9 (diff)
community/llvm3.9: fix ppc64le test error due to memory access
Diffstat (limited to 'community')
-rw-r--r--community/llvm3.9/APKBUILD4
-rw-r--r--community/llvm3.9/fix-memory-mf_exec-on-aarch64.patch2
2 files changed, 3 insertions, 3 deletions
diff --git a/community/llvm3.9/APKBUILD b/community/llvm3.9/APKBUILD
index 056aeff9328..590aeab857c 100644
--- a/community/llvm3.9/APKBUILD
+++ b/community/llvm3.9/APKBUILD
@@ -6,7 +6,7 @@ _pkgname=llvm
pkgver=3.9.1
_majorver=${pkgver%.*}
pkgname=$_pkgname$_majorver
-pkgrel=4
+pkgrel=5
pkgdesc="Low Level Virtual Machine compiler system (version $_majorver)"
arch="all"
url="http://llvm.org/"
@@ -211,7 +211,7 @@ f84cd65d7042e89826ba6e8d48c4c302bf4980da369d7f19a55f217e51c00ca8ed178d453df3a3ce
19bfb9282455d39d07dbb2b1293b03a45c57d522fbb9c5e58dac034200669628b97e7a90cd4ff5d52d9bb79acfccbef653d8a1140a7f0589ecd6f9b7c4ba0eb6 llvm-fix-DynamicLibrary-to-build-with-musl-libc.patch
6d1a716e5aa24e6b9a3acf4cc11e2504b1b01abf574074e9e5617b991de87d5e4e687eb18e85e73d5e632568afe2fc357771c4c96f9e136502071991496fb78c cmake-fix-libLLVM-name.patch
49c47f125014b60d0ea7870f981a2c1708ad705793f89287ed846ee881a837a4dc0170bf467e03f2ef56177473128945287749ac80dc2d13cfabcf8b929ba58a disable-FileSystemTest.CreateDir-perms-assert.patch
-e6d925ddc71f9f2ce8a859ac519dad51cba99c07129e378a5388bb1dd2f7d5b9d5ed392e85267fd20043789c7460a7d705eb8f970b2d130edbf5a934e9505ac4 fix-memory-mf_exec-on-aarch64.patch
+c9ef3cd95c4bd1d6ac69bbcd471b01755126d00f59d27d4a2a2ef5623943be73f8407e2fd731294d1a9d81a66e459f45f3f1d5dc5f9646f4f2fb2d8d891b5279 fix-memory-mf_exec-on-aarch64.patch
a7c6056bfa3c2b76bbbc1a663ea84e5db6e269d5360afedaad5fdc3279d4732bc414e8c7d3a3f6f0d7b30ed81d8aec3fd2b35377f81db6d441b17b185d8b9bd0 rust-lang-llvm-pr47.patch
3c35bd342de6ec40aef9af8f18cb7d9aa1d2d8e04e9f320fff7df2c828f663cc12715d86946bc6bbc19f2e99b357a07f0fd9a4acce912c9c195c6837675847d5 rust-lang-llvm-pr53.patch
4f5418082b3bb0992a57f7abbd4187d119cf277a573f899b63af93522d823f9195a754adc56ea2a8fb2f5925b39eb82975b522c30cac275c71204cbe6d809271 rust-lang-llvm-pr54.patch
diff --git a/community/llvm3.9/fix-memory-mf_exec-on-aarch64.patch b/community/llvm3.9/fix-memory-mf_exec-on-aarch64.patch
index 644c77790af..a70b3973338 100644
--- a/community/llvm3.9/fix-memory-mf_exec-on-aarch64.patch
+++ b/community/llvm3.9/fix-memory-mf_exec-on-aarch64.patch
@@ -19,7 +19,7 @@ Upstream-Issue: https://bugs.llvm.org/show_bug.cgi?id=14278#c10
return PROT_READ | PROT_WRITE | PROT_EXEC;
case llvm::sys::Memory::MF_EXEC:
-#if defined(__FreeBSD__)
-+#if defined(__FreeBSD__) || (defined(__linux__) && defined(__aarch64__))
++#if defined(__FreeBSD__) || (defined(__linux__) && (defined(__aarch64__) || defined(__powerpc64__)))
// On PowerPC, having an executable page that has no read permission
// can have unintended consequences. The function InvalidateInstruction-
// Cache uses instructions dcbf and icbi, both of which are treated by