aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-05-07 17:00:45 +0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-27 18:45:54 +0000
commit497a285ee1242b9bb7295c4bd420d2e482ef3f62 (patch)
treeaeb28f7cffa28f87c75d0a63f179b972df51abc7 /community
parent5f55129e178d8f1b89d9ae9b127e13b61a7df1ef (diff)
community/gst-plugins-ugly: upgrade to 1.16.0
Diffstat (limited to 'community')
-rw-r--r--community/gst-plugins-ugly/APKBUILD55
1 files changed, 18 insertions, 37 deletions
diff --git a/community/gst-plugins-ugly/APKBUILD b/community/gst-plugins-ugly/APKBUILD
index f0147337eff..af3040e27e2 100644
--- a/community/gst-plugins-ugly/APKBUILD
+++ b/community/gst-plugins-ugly/APKBUILD
@@ -1,24 +1,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gst-plugins-ugly
-pkgver=1.14.4
-pkgrel=1
-pkgdesc="GStreamer Multimedia Framework Ugly Plugins (gst-plugins-ugly)"
+pkgver=1.16.0
+pkgrel=0
+pkgdesc="GStreamer streaming media framework ugly plug-ins"
url="https://gstreamer.freedesktop.org"
arch="all"
license="GPL-2.0-or-later LGPL-2.0-or-later"
replaces="gst-plugins-ugly1"
-makedepends="
- a52dec-dev
- glib-dev
- gst-plugins-base-dev
- gstreamer-dev
- libcdio-dev
- libdvdread-dev
- libmpeg2-dev
- orc-dev
- x264-dev
- "
-source="https://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-$pkgver.tar.xz"
+makedepends="a52dec-dev glib-dev gst-plugins-base-dev gstreamer-dev libcdio-dev
+ libdvdread-dev libmpeg2-dev meson orc-dev x264-dev"
+source="https://gstreamer.freedesktop.org/src/gst-plugins-ugly/$pkgname-$pkgver.tar.xz"
subpackages="$pkgname-lang"
ldpath="/usr/lib/gstreamer-1.0"
@@ -28,34 +19,24 @@ ldpath="/usr/lib/gstreamer-1.0"
# - CVE-2017-5847
build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ meson \
--prefix=/usr \
--sysconfdir=/etc \
+ --mandir=/usr/share/man \
--localstatedir=/var \
- --disable-static \
- --enable-experimental \
- --enable-a52dec \
- --enable-cdio \
- --enable-dvdread \
- --enable-mpeg2dec \
- --enable-x264 \
- --disable-fatal-warnings \
- --with-package-name="GStreamer Ugly Plugins (Alpine Linux)" \
- --with-package-origin="http://alpinelinux.org/"
- make
+ --buildtype=release \
+ -Dpackage-origin="https://alpinelinux.org" \
+ -Dpackage-name="GStreamer ugly plug-ins (Alpine Linux)" \
+ . output
+ ninja -C output
}
-check() {
- cd "$builddir"
- make check
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
}
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+check() {
+ meson test -C output --print-errorlogs
}
doc() {
@@ -63,4 +44,4 @@ doc() {
replaces="${pkgname}1-doc"
}
-sha512sums="9a5fc123a8e904d6517a3946402ef27710a5e2460ebe748b3ad7b78d5092748a563f7ed4f6c734a9839e0781c2923d62425aa65f3d7469d7083861264f831cf1 gst-plugins-ugly-1.14.4.tar.xz"
+sha512sums="7ecbd3ddc3034dfaa3ce7d118589c856e99e8da734e8d1dd70ab70f4aa3d11d78bd55b6c6134eddaa0b6e627015b1f663c0439367bba305c7d7d46a387470d2e gst-plugins-ugly-1.16.0.tar.xz"