aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-05-18 02:43:49 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-18 02:50:10 +0200
commit51026c10c08d90ed6e8f17d994273aa55538bfd3 (patch)
tree7884c7cc1b1f5d6f1b7a558982dd7cd7f37be564 /community
parent2daed3ee9817e38b4b08d9e7b82993bc18480549 (diff)
community/openjdk8: ensure that pkgver matches source version
Diffstat (limited to 'community')
-rw-r--r--community/openjdk8/APKBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/community/openjdk8/APKBUILD b/community/openjdk8/APKBUILD
index 62aa8c6d0df..bf3a83262ac 100644
--- a/community/openjdk8/APKBUILD
+++ b/community/openjdk8/APKBUILD
@@ -81,6 +81,11 @@ unpack() {
prepare() {
cd "$builddir"
+ local ver_u=$(sed -En 's/^JDK_UPDATE_VERSION\s*=\s*(\S+).*/\1/p' Makefile.am)
+ local ver_b=$(sed -En 's/^BUILD_VERSION\s*=\s*b(\S+).*/\1/p' Makefile.am)
+ [ "${pkgver#*.}" = "$ver_u.$ver_b" ] \
+ || die "Version mismatch, source is 8.$ver_u.$ver_b, but abuild defines $pkgver!"
+
# Busybox sha256 does not support longopts.
sed -e "s/--check/-c/g" -i Makefile.am