aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-12-23 19:38:09 +0200
committerTimo Teräs <timo.teras@iki.fi>2015-12-23 19:39:02 +0200
commit51dfbc3c09e8cc0d713af81923bbc99aa0f80f65 (patch)
tree3ec5909fe9b707e01b7cea875594cb22c8b6a463 /community
parent3ff9f120d935865cea6e006ea7ba1131f8dafac9 (diff)
community/inkscape: fix crash on startup
Diffstat (limited to 'community')
-rw-r--r--community/inkscape/APKBUILD12
-rw-r--r--community/inkscape/fix-crash.patch16
2 files changed, 24 insertions, 4 deletions
diff --git a/community/inkscape/APKBUILD b/community/inkscape/APKBUILD
index 5b42732272d..d6e3c76a4c4 100644
--- a/community/inkscape/APKBUILD
+++ b/community/inkscape/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=inkscape
pkgver=0.91
-pkgrel=5
+pkgrel=6
pkgdesc="A vector-based drawing program - svg compliant"
url="http://inkscape.sourceforge.net/"
arch="all"
@@ -27,6 +27,7 @@ depends="desktop-file-utils"
install=
subpackages="$pkgname-doc $pkgname-lang $pkgname-view"
source="https://launchpad.net/inkscape/$pkgver.x/$pkgver/+download/inkscape-$pkgver.tar.bz2
+ fix-crash.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -77,6 +78,9 @@ doc() {
"$pkgdir"/usr/share/inkscape/tutorials \
"$subpkgdir"/usr/share/inkscape
}
-md5sums="278dfa4514adcde23546370ec2c84581 inkscape-0.91.tar.bz2"
-sha256sums="4d901f8a9e1924404e797ad23b8b0c495a9d155448816d95a55974314e1f141b inkscape-0.91.tar.bz2"
-sha512sums="3778ef7d4a1c759a7afc093e55eefb69a78dcb60332655cc8ab8c481f54a3e6550df6070178390eb08588245531906b8bef33301f0765a4d28d6c7506fcf3bc7 inkscape-0.91.tar.bz2"
+md5sums="278dfa4514adcde23546370ec2c84581 inkscape-0.91.tar.bz2
+e2cfb1380608e08a56d20ced3dacfea0 fix-crash.patch"
+sha256sums="4d901f8a9e1924404e797ad23b8b0c495a9d155448816d95a55974314e1f141b inkscape-0.91.tar.bz2
+83feb2e58445c034cc13bd09350ff9cd08cee6421a13d8debecdfd35d62659e5 fix-crash.patch"
+sha512sums="3778ef7d4a1c759a7afc093e55eefb69a78dcb60332655cc8ab8c481f54a3e6550df6070178390eb08588245531906b8bef33301f0765a4d28d6c7506fcf3bc7 inkscape-0.91.tar.bz2
+d91a72c4363a5cd736593478580ef6175f6a7db0b601bf3a4af5c97c4bd1c295feb9e31365d5185be4d9cf4fddd642821a43337d914d6c257bef6c450d7ef70a fix-crash.patch"
diff --git a/community/inkscape/fix-crash.patch b/community/inkscape/fix-crash.patch
new file mode 100644
index 00000000000..e28aac49d2c
--- /dev/null
+++ b/community/inkscape/fix-crash.patch
@@ -0,0 +1,16 @@
+From: Timo Teräs <timo.teras@iki.fi>
+
+Remove redundant object instantiation which yields returning c_str to
+temporary stack object.
+
+--- inkscape-0.91/src/libnrtype/FontFactory.cpp 2015-12-23 19:36:15.310394043 +0200
++++ inkscape-0.91/src/libnrtype/FontFactory.cpp 2015-12-23 19:35:31.876527221 +0200
+@@ -194,7 +194,7 @@
+ const char *pangoFamily = pango_font_description_get_family(fontDescr);
+
+ if (pangoFamily && ((it = fontNameMap.find(pangoFamily)) != fontNameMap.end())) {
+- return ((Glib::ustring)it->second).c_str();
++ return it->second.c_str();
+ }
+
+ return pangoFamily;