aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-08 05:01:36 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-11 10:21:04 +0000
commit5325b82fd7fbec548d8e6fa412c127ac1a046555 (patch)
tree6cdf3b570fbbd91cded9bc75b183109d3312be17 /community
parent65c5c781696b4243350ff538fe70bfa1105e7453 (diff)
community/xdriinfo: move from main
Diffstat (limited to 'community')
-rw-r--r--community/xdriinfo/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/xdriinfo/APKBUILD b/community/xdriinfo/APKBUILD
new file mode 100644
index 00000000000..ebda02633f0
--- /dev/null
+++ b/community/xdriinfo/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xdriinfo
+pkgver=1.0.5
+pkgrel=1
+pkgdesc="query configuration information of DRI drivers"
+url="http://xorg.freedesktop.org/"
+arch="all"
+license="custom"
+subpackages="$pkgname-doc"
+makedepends="libx11-dev mesa-dev xorgproto"
+depends=
+source="https://www.x.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+sha512sums="6b7a3641f488d305f950c494464fd4b674ab3aaed5c7159d6d8ddad4587c18d680e5854bd80666444f1dee52eb4f46b45709a6d9c333593fe045c73e738524de xdriinfo-1.0.5.tar.bz2"