aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-06-19 15:25:37 +0300
committerTimo Teräs <timo.teras@iki.fi>2017-06-19 15:25:37 +0300
commit57f6e7c8080c374a95d46f54b260c30d61e45e7c (patch)
tree12432c996ce6a00c60de2a3e868e43440ce9866a /community
parentbbff2dbbfb18d91405a9314b20ae5581d9988f2a (diff)
community/go: fix subpkgdir vs. pkgdir
Diffstat (limited to 'community')
-rw-r--r--community/go/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index 43f9ea9c4b1..886c45216e4 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -120,16 +120,16 @@ package() {
# bug (https://github.com/golang/go/issues/2775).
# When this is resolved we can split out the source to a
# go-src sub package.
- mkdir -p "$subpkgdir"/usr/lib/go/
- cp -a "$builddir"/src "$subpkgdir"/usr/lib/go
+ mkdir -p "$pkgdir"/usr/lib/go/
+ cp -a "$builddir"/src "$pkgdir"/usr/lib/go
# Remove tests from /usr/lib/go/src.
# Those shouldn't be affacted by the upstream bug (see above).
- find "$subpkgdir"/usr/lib/go/src \( -type f -a -name "*_test.go" \) \
+ find "$pkgdir"/usr/lib/go/src \( -type f -a -name "*_test.go" \) \
-exec rm -rf \{\} \+
- find "$subpkgdir"/usr/lib/go/src \( -type d -a -name "testdata" \) \
+ find "$pkgdir"/usr/lib/go/src \( -type d -a -name "testdata" \) \
-exec rm -rf \{\} \+
- find "$subpkgdir"/usr/lib/go/src -type f -a \( -name "*.bash" -o -name "*.rc" -o -name "*.bat" \) \
+ find "$pkgdir"/usr/lib/go/src -type f -a \( -name "*.bash" -o -name "*.rc" -o -name "*.bat" \) \
-exec rm -rf \{\} \+
}