aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-06 12:11:53 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-06 12:18:06 +0000
commit5fcf9eb2802c57bb047905e3047d391142e52041 (patch)
treecda92d76381d7760edf5ae98c75650d62aca76a9 /community
parente5ab1fc88b1ff6b7c01adbb6dccf39b70f6cc16d (diff)
community/perl-c*: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - Rename _builddir to builddir - Add missing default_prepare in prepare()
Diffstat (limited to 'community')
-rw-r--r--community/perl-cisco-copyconfig/APKBUILD19
-rw-r--r--community/perl-class-accessor-lite/APKBUILD23
-rw-r--r--community/perl-class-dbi/APKBUILD21
-rw-r--r--community/perl-class-factory-util/APKBUILD15
-rw-r--r--community/perl-class-trigger/APKBUILD21
-rw-r--r--community/perl-config-simple/APKBUILD35
-rw-r--r--community/perl-config-tiny/APKBUILD25
-rw-r--r--community/perl-cpan-meta-check/APKBUILD15
-rw-r--r--community/perl-crypt-openssl-bignum/APKBUILD23
9 files changed, 122 insertions, 75 deletions
diff --git a/community/perl-cisco-copyconfig/APKBUILD b/community/perl-cisco-copyconfig/APKBUILD
index a84681494d2..0210372edea 100644
--- a/community/perl-cisco-copyconfig/APKBUILD
+++ b/community/perl-cisco-copyconfig/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-cisco-copyconfig
_pkgreal=Cisco-CopyConfig
pkgver=1.4
-pkgrel=0
+pkgrel=1
pkgdesc="Perl module for Cisco-CopyConfig"
url="http://search.cpan.org/dist/Cisco-CopyConfig/"
arch="noarch"
@@ -18,27 +18,30 @@ source="http://www.cpan.org/authors/id/A/AA/AARONSCA/$_pkgreal-$pkgver.tgz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
cd "$builddir"
if [ -e Build.PL ]; then
- perl Build.PL installdirs=vendor || return 1
+ perl Build.PL installdirs=vendor
else
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
fi
}
build() {
cd "$builddir"
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="3f59b3c18e42ffcbe3a9726e7dac3182 Cisco-CopyConfig-1.4.tgz"
-sha256sums="a2e1bbe2c3cac987c6947e76ca92167f569dfce45c788d00a6274dfa998a0aa9 Cisco-CopyConfig-1.4.tgz"
sha512sums="80ee4e38bb3db9778bed6469fd2d650f74e793380f26c3e0d28e91d35f434ffb7c8fe8e99c98e4d72b2c3b2df931ac0776a83e0cbed977fb0b60f12a6007516b Cisco-CopyConfig-1.4.tgz"
diff --git a/community/perl-class-accessor-lite/APKBUILD b/community/perl-class-accessor-lite/APKBUILD
index 40ea2a5a176..720e566ab44 100644
--- a/community/perl-class-accessor-lite/APKBUILD
+++ b/community/perl-class-accessor-lite/APKBUILD
@@ -4,8 +4,8 @@
pkgname=perl-class-accessor-lite
_pkgreal=Class-Accessor-Lite
pkgver=0.08
-pkgrel=0
-pkgdesc="a minimalistic variant of Class::Accessor"
+pkgrel=1
+pkgdesc="A minimalistic variant of Class::Accessor"
url="http://search.cpan.org/dist/Class-Accessor-Lite/"
arch="noarch"
license="GPL PerlArtistic"
@@ -16,21 +16,28 @@ makedepends="perl-dev perl-module-install $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/K/KA/KAZUHO/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ default_prepare
+
+ cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
- make && make test
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
diff --git a/community/perl-class-dbi/APKBUILD b/community/perl-class-dbi/APKBUILD
index 32dd7050b4a..cab639dca9c 100644
--- a/community/perl-class-dbi/APKBUILD
+++ b/community/perl-class-dbi/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-class-dbi
_pkgreal=Class-DBI
pkgver=v3.0.17
-pkgrel=0
+pkgrel=1
pkgdesc="Simple Database Abstraction"
url="http://search.cpan.org/dist/Class-DBI/"
arch="noarch"
@@ -16,21 +16,28 @@ makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/T/TM/TMTM/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ default_prepare
+
+ cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
- make && make test
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
diff --git a/community/perl-class-factory-util/APKBUILD b/community/perl-class-factory-util/APKBUILD
index 89b6fe6f336..55e1c74ed38 100644
--- a/community/perl-class-factory-util/APKBUILD
+++ b/community/perl-class-factory-util/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-class-factory-util
_pkgreal=Class-Factory-Util
pkgver=1.7
-pkgrel=0
+pkgrel=1
pkgdesc="Perl module for Class-Factory-Util"
url="http://search.cpan.org/dist/Class-Factory-Util/"
arch="noarch"
@@ -18,7 +18,7 @@ source="http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/$_pkgreal-$pkgver.ta
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
@@ -28,15 +28,18 @@ prepare() {
build() {
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="aebd79da361b676a7ecd3245fc3d1b3f Class-Factory-Util-1.7.tar.gz"
-sha256sums="6c516b445b44f87363fb3a148431d31e9ecb5e6f21fb6481c89b2406b6692e26 Class-Factory-Util-1.7.tar.gz"
sha512sums="8b8af36f1100805a9f59bd8745bc41455ebc20af9ff9cedd8a36370f66e0fb63a761918ae4f268d5546aeeecdd4ca7de448aca36e84f27b8f0932f34db68982e Class-Factory-Util-1.7.tar.gz"
diff --git a/community/perl-class-trigger/APKBUILD b/community/perl-class-trigger/APKBUILD
index 92e61af7bbe..0f4984deee5 100644
--- a/community/perl-class-trigger/APKBUILD
+++ b/community/perl-class-trigger/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-class-trigger
_pkgreal=Class-Trigger
pkgver=0.14
-pkgrel=1
+pkgrel=2
pkgdesc="Mixin to add / call inheritable triggers"
url="http://search.cpan.org/dist/Class-Trigger/"
arch="noarch"
@@ -16,21 +16,28 @@ makedepends="perl-dev $cpanmakedepends perl-module-install"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/M/MI/MIYAGAWA/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ default_prepare
+
+ cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
- make && make test
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
diff --git a/community/perl-config-simple/APKBUILD b/community/perl-config-simple/APKBUILD
index 87d5e915605..19239ed80fa 100644
--- a/community/perl-config-simple/APKBUILD
+++ b/community/perl-config-simple/APKBUILD
@@ -4,38 +4,43 @@
pkgname=perl-config-simple
_pkgreal=Config-Simple
pkgver=4.59
-pkgrel=0
-pkgdesc="simple configuration file class"
+pkgrel=1
+pkgdesc="Simple configuration file class"
url="http://search.cpan.org/dist/Config-Simple/"
arch="noarch"
license="GPL PerlArtistic"
cpandepends=""
-cpanmakedepends=" "
+cpanmakedepends=""
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/S/SH/SHERZODR/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ default_prepare
+
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
- find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="96513b61c7db591339ce2577878a3b32 Config-Simple-4.59.tar.gz"
-sha256sums="cb78a975ad8463f992f35f392227aaf188d533c9092373742b3c2bb592781054 Config-Simple-4.59.tar.gz"
sha512sums="23eb4f5ace1288c3d2a6105fa109d08e8170f4c1b5f6a28b460bb9e0fb62c66c7d392712fca0c96d83c4a16f5c940fcbc348d700a7bef86bf2ba37cd114c8a14 Config-Simple-4.59.tar.gz"
diff --git a/community/perl-config-tiny/APKBUILD b/community/perl-config-tiny/APKBUILD
index e514e7d353f..9c0d40c5938 100644
--- a/community/perl-config-tiny/APKBUILD
+++ b/community/perl-config-tiny/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-config-tiny
_pkgreal=Config-Tiny
pkgver=2.23
-pkgrel=0
+pkgrel=1
pkgdesc="Perl module for Config-Tiny"
url="http://search.cpan.org/dist/Config-Tiny/"
arch="noarch"
@@ -16,29 +16,32 @@ makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/R/RS/RSAVAGE/$_pkgreal-$pkgver.tgz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
if [ -e Build.PL ]; then
- perl Build.PL installdirs=vendor || return 1
+ perl Build.PL installdirs=vendor
else
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
fi
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="6c3bc610c4bc587e1441e651e01584ce Config-Tiny-2.23.tgz"
-sha256sums="9a8a66e3ed420cbc6585c43abeff788368309a46355cf69a64c2a47e1911e50c Config-Tiny-2.23.tgz"
sha512sums="c5c77aa18a387f181ba9bb2df8859c328073521e14163fe04fd7a104928bd68cf654eab88d24bd23e556e6ecc139dfed716fb7b8119e98cd2ab6f6915c976f01 Config-Tiny-2.23.tgz"
diff --git a/community/perl-cpan-meta-check/APKBUILD b/community/perl-cpan-meta-check/APKBUILD
index c4f960f46b9..7fe544ebb90 100644
--- a/community/perl-cpan-meta-check/APKBUILD
+++ b/community/perl-cpan-meta-check/APKBUILD
@@ -4,13 +4,13 @@
pkgname=perl-cpan-meta-check
_pkgreal=CPAN-Meta-Check
pkgver=0.014
-pkgrel=0
+pkgrel=1
pkgdesc="Verify requirements in a CPAN::Meta object"
url="http://search.cpan.org/dist/CPAN-Meta-Check/"
arch="noarch"
license="GPL PerlArtistic"
cpandepends=""
-cpanmakedepends="perl-test-deep "
+cpanmakedepends="perl-test-deep"
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
@@ -18,7 +18,7 @@ source="http://search.cpan.org/CPAN/authors/id/L/LE/LEONT/$_pkgreal-$pkgver.tar.
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
@@ -28,12 +28,17 @@ prepare() {
build() {
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
diff --git a/community/perl-crypt-openssl-bignum/APKBUILD b/community/perl-crypt-openssl-bignum/APKBUILD
index 70b7852534e..4a20fe67129 100644
--- a/community/perl-crypt-openssl-bignum/APKBUILD
+++ b/community/perl-crypt-openssl-bignum/APKBUILD
@@ -4,35 +4,42 @@
pkgname=perl-crypt-openssl-bignum
_pkgreal=Crypt-OpenSSL-Bignum
pkgver=0.08
-pkgrel=1
+pkgrel=2
pkgdesc="OpenSSL's multiprecision integer arithmetic"
url="http://search.cpan.org/dist/Crypt-OpenSSL-Bignum/"
arch="all"
license="GPL PerlArtistic"
cpandepends=""
-cpanmakedepends=" "
+cpanmakedepends=""
depends="$cpandepends"
makedepends="perl-dev libressl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/K/KM/KMX/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ default_prepare
+
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}