aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 12:12:48 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 13:00:04 +0000
commit7ff0555dbb04c7cf4c41bc7ea396d8f8477eca16 (patch)
tree51bd6925f80145e5baad07c0988af67a992aa4d2 /community
parent298b2e0fd138fda3e6e3762ac2eb067098ef09c9 (diff)
community/py-sip: moved from testing
Diffstat (limited to 'community')
-rw-r--r--community/py-sip/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/py-sip/APKBUILD b/community/py-sip/APKBUILD
new file mode 100644
index 00000000000..dd33c297f14
--- /dev/null
+++ b/community/py-sip/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-sip
+_pkgname=sip
+pkgver=4.18.1
+pkgrel=0
+pkgdesc="A tool that makes it easy to create Python bindings for C and C++ libraries"
+url="http://www.riverbankcomputing.com/software/sip/"
+arch="all"
+license="custom:sip"
+depends=""
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://sourceforge.net/projects/pyqt/files/sip/sip-$pkgver/sip-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ local sip_api_major_nr=$(sed -nre 's:^#define SIP_API_MAJOR_NR\s+([0-9]+):\1:p' siplib/sip.h.in)
+ python configure.py
+ make CC="${CC:-gcc}" \
+ CXX="${CXX:-g++}" \
+ CFLAGS="$CFLAGS -fPIC" \
+ CXXFLAGS="$CXXFLAGS" \
+ || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/custom/${pkgname}/LICENSE
+}
+
+md5sums="9d664c33e8d0eabf1238a7ff44a399e9 sip-4.18.1.tar.gz"
+sha256sums="9bce7a2dbf7f105bf68ad1bab58eebc0ce33087ec40396da756463f086ffa290 sip-4.18.1.tar.gz"
+sha512sums="c4277fa113bf5e28d8a19388f160456654e4ccbbc2adc1209677e95e1efad427ce641ef09875ec0a59e555578986671261dd4c3ac52c673b5803f188fc311222 sip-4.18.1.tar.gz"