aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-07-21 15:30:55 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-07-21 15:34:40 +0000
commit85cf3a23470c07ce4a6152ef5b21be366d14d684 (patch)
tree03516d8986dd25bfbff1a21d653ddc43d7ecdc95 /community
parentda31d76c19084dd733dbf58544ac4c7dac84b95a (diff)
community/openjdk8: upgrade to icedtea 3.5.0 / java 8 u141 b15
fixes #7579 S8163958, CVE-2017-10102: Improved garbage collection S8167228: Update to libpng 1.6.28 S8169209, CVE-2017-10053: Improved image post-processing steps S8169392, CVE-2017-10067: Additional jar validation steps S8170966, CVE-2017-10081: Right parenthesis issue S8171539, CVE-2017-10078: Better script accessibility for JavaScript S8172204, CVE-2017-10087: Better Thread Pool execution S8172461, CVE-2017-10089: Service Registration Lifecycle S8172465, CVE-2017-10090: Better handling of channel groups S8172469, CVE-2017-10096: Transform Transformer Exceptions S8173286, CVE-2017-10101: Better reading of text catalogs S8173697, CVE-2017-10107: Less Active Activations S8173770, CVE-2017-10074: Image conversion improvements S8174098, CVE-2017-10110: Better image fetching S8174105, CVE-2017-10108: Better naming attribution S8174113, CVE-2017-10109: Better sourcing of code S8174770: Check registry registration location S8174873: Improved certificate procesing S8175106, CVE-2017-10115: Higher quality DSA operations S8175110, CVE-2017-10118: Higher quality ECDSA operations S8176055: JMX diagnostic improvements S8176067, CVE-2017-10116: Proper directory lookup processing S8176760, CVE-2017-10135: Better handling of PKCS8 material S8178135, CVE-2017-10176: Additional elliptic curve support S8179101, CVE-2017-10193: Improve algorithm constraints implementation S8179998, CVE-2017-10198: Clear certificate chain connections S8181420, CVE-2017-10074: PPC: Image conversion improvements S8183551, CVE-2017-10074, PR3423: AArch64: Image conversion improvements S8184185, CVE-2017-10111: Rearrange MethodHandle arrangements
Diffstat (limited to 'community')
-rw-r--r--community/openjdk8/APKBUILD28
-rw-r--r--community/openjdk8/icedtea-hotspot-musl.patch113
-rw-r--r--community/openjdk8/icedtea-hotspot-uclibc-fixes.patch93
3 files changed, 104 insertions, 130 deletions
diff --git a/community/openjdk8/APKBUILD b/community/openjdk8/APKBUILD
index a954089bd06..a22fae563ae 100644
--- a/community/openjdk8/APKBUILD
+++ b/community/openjdk8/APKBUILD
@@ -2,11 +2,11 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Timo Teras <timo.teras@iki.fi>
pkgname=openjdk8
-_icedteaver=3.4.0
+_icedteaver=3.5.0
# pkgver is <JDK version>.<JDK update>.<JDK build>
# Check http://icedtea.classpath.org/wiki/Main_Page when updating!
-pkgver=8.131.11
-pkgrel=2
+pkgver=8.141.15
+pkgrel=0
pkgdesc="OpenJDK 8 provided by IcedTea"
url="http://icedtea.classpath.org/"
arch="all"
@@ -58,7 +58,6 @@ source="http://icedtea.classpath.org/download/source/icedtea-$_icedteaver.tar.gz
icedtea-hotspot-musl.patch
icedtea-hotspot-musl-ppc.patch
icedtea-hotspot-noagent-musl.patch
- icedtea-hotspot-uclibc-fixes.patch
icedtea-jdk-execinfo.patch
icedtea-jdk-fix-ipv6-init.patch
icedtea-jdk-fix-libjvm-load.patch
@@ -267,20 +266,19 @@ demos() {
"$subpkgdir"/$_java_home/
}
-sha512sums="78d3004626138430c5a3d956b652ad2ad57da7732d210baa0f31a83b4ce93b4feb32da6e8655838c7dc3b66a1170377456f5da89077ee9cd3b18ee9c76dce8f1 icedtea-3.4.0.tar.gz
-f3cca223bd39c0202dd1a65a38ca17024b6cb5c82d833946ec1b7d28d205833b4dd2dadde505a1c2384e3b28ff0d21a4f175e064b8ac82aa8a07508e53cdc722 openjdk-3.4.0.tar.xz
-f0579608ab1342df231c4542dab1c40e648cda8e9780ea584fd47679b07c93508cbfa85f0406d8aa8b9d528fc5bd99c9d41469568fbec41a6456a13d914ac71c corba-3.4.0.tar.xz
-ef3ed47815e6d15f40c5947fee1058c252ac673f70b6bf7c30505faa12fa5cbab8168d816abe7791dc88acec457744883db4c0af23fb2166bbb709e870685bcd jaxp-3.4.0.tar.xz
-867cac2919e715190596ae4f73fa42c6cba839ba48ae940adcef20abfb23ffeeaa2501c4aedc214b3595bc4e2a4eea9fa7e7cac62a3420a11fb30a1f7edc9254 jaxws-3.4.0.tar.xz
-180d7b4435e465d68ed0b420b42dddc598c872075e225b8885ae1833fa4ab5034ce5083c4dfba516a21b2d472321b37a01ba92793e17c78e9fddb1e254f12065 jdk-3.4.0.tar.xz
-0663f40b07de88cd7939557bf7fdb92077d7ca2132e369caefa82db887261ea02102864d33ec0fef3b2c80dd366d25dbc1a95144139498be581dfabe913e4312 langtools-3.4.0.tar.xz
-29bc953d283f0a0a464fa150e2c4d71b0adaa29da67246843d230f370b5a20227fb40ef6a7e3b93f10b0cdec18b0cd2bbbceeaea3c9db4d64c158cc23babbad2 hotspot-3.4.0.tar.xz
-79b5095bab447d1911696bc1e328fb72c08764c0139cab14a28c0f6c2e49a2d96bb06fbbb85523b2586672cb0f13709c3158823d5ac3f3fe3f0f88402d3cb246 nashorn-3.4.0.tar.xz
+sha512sums="0fc51b7e8b39670b1439cdfb947e215d6c92e64950002aa7b63a7051a27f60335aa477f166e0ee43b70faf19bb1c67678b458e0cec4333b20d76484ebcb5c476 icedtea-3.5.0.tar.gz
+88f6dabebe20f9feedf1de69c486fb8d1d4239b25f845c998c64cf6f1f783cf86cc98feb87f50a5256a2a340e23d2d3452827c39a65e371e54477479ee2b7be4 openjdk-3.5.0.tar.xz
+37d42af8663ac0af58c494406360e421dd1f707d98b9a00bb0149a51ccdee809524bc1f307d207360e7bc3f1c0d6a585c085ad0395075a54553226b9fb1874a4 corba-3.5.0.tar.xz
+70f9c3c8beb119760356c46c64cc382c783d4aa4f940627169541ea98c07b32af1c67f266a24c6f211e9eb4c37e25a8d124868abfbe7538787a17e66a731f93f jaxp-3.5.0.tar.xz
+ff10229eeefc1cc08f6f7216b985f092b0bdcc10a33c1c9a962120e93e7ad3d15672b22ac73f3218a59334bf585d8116203d87883f07a5a2a1c2403007fd6720 jaxws-3.5.0.tar.xz
+caeafb2efdfb6cacedab1fe13f23822baf5dcd599403a4cc057e6814d224cdf2ec5cdfb8c55ab8a5efb1e0f68b2d784226431a54e3711aa99dbee4ac20ef60fa jdk-3.5.0.tar.xz
+8260e326b3aa42f8ec9de18a7b8eeaa52b2610f63426d7a1a143a7f27b849c60a9a47397de565bc3fb0e9761178e2cb68af15c996d848e20f5016111dd22a4cd langtools-3.5.0.tar.xz
+098251daba090465cffebc7fe8486140709726607b93aacd9052a85903fb252aef689611f85deb5324a99e037256cef18a8035fc3d47c8a38b2b47f0e7d1c70d hotspot-3.5.0.tar.xz
+ac0c7adce68d3e85bd708b055b8a1661ac9a24301a10c009f030be947d194cf8f7cf856923ddfc29b6c2d61ea62d7fdfc260abc4664fb0f3bdaf1e9ecdc767d7 nashorn-3.5.0.tar.xz
1f470432275d5beaa8b4e4352a2f24a4a00593546dc4f3bd857794c89e521e8e6d6abc540762bbd769be3e1e3da058e134dc5dc066d12b9b8a1f0656040a795c fix-paxmark.patch
-ada3bc4024682bfb86ebf3850d3a36cf4c0f0677a6d56eac2e0959b92bfe759010d5b9c801b043cae3ca8418d7819546ae245ac163df83e48c5d4b34478daeb0 icedtea-hotspot-musl.patch
+bfa16565d71453a0ba4204cb7ee0f8cb8c9a272c4d71d1357af4425183e64ef8df77ae1df1bbb0f984cf2d6d04a49124a6ef50f09dfee80c5b5734596e0b2a8e icedtea-hotspot-musl.patch
e5cf4d70f96fc1e72ae8b97a887adb96092ff36584711cbb8de9d9fa9e859cb8731d638838de0d9591239fc44ffe5c74422d1842bd9f10a0c00dff1627bdeeef icedtea-hotspot-musl-ppc.patch
3c592a14f1806a431290a96a8c1413ca1cc621e73a87ed778fa98878c82809bd924072210d4e4127a6c0c32ff557d749f6c9b3ce31cbca083b013240b618b224 icedtea-hotspot-noagent-musl.patch
-822eee0dc4d3ba677a289dfeb3668b536d2d626708390a9d9702fb4144a481fd443a215a0d2041c6026113837aafa4ba0b5e9ead8589d2da6717a238bbc95a5a icedtea-hotspot-uclibc-fixes.patch
f6365cfafafa008bd6c1bf0ccec01a63f8a39bd1a8bc87baa492a27234d47793ba02d455e5667a873ef50148df3baaf6a8421e2da0b15faac675867da714dd5f icedtea-jdk-execinfo.patch
48533f87fc2cf29d26b259be0df51087d2fe5b252e72d00c6ea2f4add7b0fb113141718c116279c5905e03f64a1118082e719393786811367cf4d472b5d36774 icedtea-jdk-fix-ipv6-init.patch
b135991c76b0db8fa7c363e0903624668e11eda7b54a943035c214aa4d7fc8c3e8110ed200edcec82792f3c9393150a9bd628625ddf7f3e55720ff163fbbb471 icedtea-jdk-fix-libjvm-load.patch
diff --git a/community/openjdk8/icedtea-hotspot-musl.patch b/community/openjdk8/icedtea-hotspot-musl.patch
index af64b27c034..3c9be118c2d 100644
--- a/community/openjdk8/icedtea-hotspot-musl.patch
+++ b/community/openjdk8/icedtea-hotspot-musl.patch
@@ -1,6 +1,8 @@
---- openjdk.orig/hotspot/src/os/linux/vm/jvm_linux.cpp
+diff --git icedtea/hotspot/src/os/linux/vm/jvm_linux.cpp icedtea/hotspot/src/os/linux/vm/jvm_linux.cpp
+index ba84788..c22281f 100644
+--- openjdk/hotspot/src/os/linux/vm/jvm_linux.cpp
+++ openjdk/hotspot/src/os/linux/vm/jvm_linux.cpp
-@@ -154,7 +154,9 @@
+@@ -154,7 +154,9 @@ struct siglabel siglabels[] = {
#ifdef SIGSTKFLT
"STKFLT", SIGSTKFLT, /* Stack fault. */
#endif
@@ -10,9 +12,57 @@
"CHLD", SIGCHLD, /* Child status has changed (POSIX). */
"CONT", SIGCONT, /* Continue (POSIX). */
"STOP", SIGSTOP, /* Stop, unblockable (POSIX). */
---- openjdk.orig/hotspot/src/os/linux/vm/os_linux.inline.hpp
+diff --git icedtea/hotspot/src/os/linux/vm/os_linux.cpp icedtea/hotspot/src/os/linux/vm/os_linux.cpp
+index 89ba0ff..e84837a 100644
+--- openjdk/hotspot/src/os/linux/vm/os_linux.cpp
++++ openjdk/hotspot/src/os/linux/vm/os_linux.cpp
+@@ -94,7 +94,6 @@
+ # include <string.h>
+ # include <syscall.h>
+ # include <sys/sysinfo.h>
+-# include <gnu/libc-version.h>
+ # include <sys/ipc.h>
+ # include <sys/shm.h>
+ # include <link.h>
+@@ -530,6 +529,13 @@ void os::Linux::hotspot_sigmask(Thread* thread) {
+ // detecting pthread library
+
+ void os::Linux::libpthread_init() {
++#if 1
++ // Hard code Alpine Linux supported musl compatible settings
++ os::Linux::set_glibc_version("glibc 2.9");
++ os::Linux::set_libpthread_version("NPTL");
++ os::Linux::set_is_NPTL();
++ os::Linux::set_is_floating_stack();
++#else
+ // Save glibc and pthread version strings. Note that _CS_GNU_LIBC_VERSION
+ // and _CS_GNU_LIBPTHREAD_VERSION are supported in glibc >= 2.3.2. Use a
+ // generic name for earlier versions.
+@@ -588,6 +594,7 @@ void os::Linux::libpthread_init() {
+ if (os::Linux::is_NPTL() || os::Linux::supports_variable_stack_size()) {
+ os::Linux::set_is_floating_stack();
+ }
++#endif
+ }
+
+ /////////////////////////////////////////////////////////////////////////////
+@@ -2830,6 +2837,11 @@ extern "C" JNIEXPORT void numa_warn(int number, char *where, ...) { }
+ extern "C" JNIEXPORT void numa_error(char *where) { }
+ extern "C" JNIEXPORT int fork1() { return fork(); }
+
++static void *dlvsym(void *handle, const char *name, const char *ver)
++{
++ return dlsym(handle, name);
++}
++
+ // Handle request to load libnuma symbol version 1.1 (API v1). If it fails
+ // load symbol from base version instead.
+ void* os::Linux::libnuma_dlsym(void* handle, const char *name) {
+diff --git openjdk/hotspot/src/os/linux/vm/os_linux.inline.hpp openjdk/hotspot/src/os/linux/vm/os_linux.inline.hpp
+index 10d56d8..b9b2b77 100644
+--- openjdk/hotspot/src/os/linux/vm/os_linux.inline.hpp
+++ openjdk/hotspot/src/os/linux/vm/os_linux.inline.hpp
-@@ -52,7 +52,7 @@
+@@ -33,7 +33,7 @@
#include <unistd.h>
#include <sys/socket.h>
@@ -21,9 +71,24 @@
#include <netdb.h>
inline void* os::thread_local_storage_at(int index) {
---- openjdk.orig/hotspot/src/os_cpu/linux_x86/vm/os_linux_x86.cpp
+diff --git openjdk/hotspot/src/os_cpu/linux_aarch64/vm/os_linux_aarch64.cpp openjdk/hotspot/src/os_cpu/linux_aarch64/vm/os_linux_aarch64.cpp
+index d2c10e0..20f657f 100644
+--- openjdk/hotspot/src/os_cpu/linux_aarch64/vm/os_linux_aarch64.cpp
++++ openjdk/hotspot/src/os_cpu/linux_aarch64/vm/os_linux_aarch64.cpp
+@@ -75,7 +75,7 @@
+ # include <pwd.h>
+ # include <poll.h>
+ # include <ucontext.h>
+-# include <fpu_control.h>
++# include <linux/types.h> /* provides __u64 */
+
+ #ifdef BUILTIN_SIM
+ #define REG_SP REG_RSP
+diff --git openjdk/hotspot/src/os_cpu/linux_x86/vm/os_linux_x86.cpp openjdk/hotspot/src/os_cpu/linux_x86/vm/os_linux_x86.cpp
+index 38388cb..2505ba8 100644
+--- openjdk/hotspot/src/os_cpu/linux_x86/vm/os_linux_x86.cpp
+++ openjdk/hotspot/src/os_cpu/linux_x86/vm/os_linux_x86.cpp
-@@ -73,7 +73,6 @@
+@@ -72,7 +72,6 @@
# include <pwd.h>
# include <poll.h>
# include <ucontext.h>
@@ -31,17 +96,19 @@
#ifdef AMD64
#define REG_SP REG_RSP
-@@ -532,6 +531,9 @@
-
+@@ -543,6 +542,9 @@ JVM_handle_linux_signal(int sig,
ShouldNotReachHere();
}
-+
+
+#define _FPU_GETCW(cw) __asm__ __volatile__ ("fnstcw %0" : "=m" (*&cw))
+#define _FPU_SETCW(cw) __asm__ __volatile__ ("fldcw %0" : : "m" (*&cw))
-
++
void os::Linux::init_thread_fpu_state(void) {
#ifndef AMD64
---- openjdk.orig/hotspot/src/os_cpu/linux_x86/vm/threadLS_linux_x86.hpp
+ // set fpu to 53 bit precision
+diff --git openjdk/hotspot/src/os_cpu/linux_x86/vm/threadLS_linux_x86.hpp openjdk/hotspot/src/os_cpu/linux_x86/vm/threadLS_linux_x86.hpp
+index f3f2f26..6b50cfa 100644
+--- openjdk/hotspot/src/os_cpu/linux_x86/vm/threadLS_linux_x86.hpp
+++ openjdk/hotspot/src/os_cpu/linux_x86/vm/threadLS_linux_x86.hpp
@@ -32,7 +32,9 @@
// map stack pointer to thread pointer - see notes in threadLS_linux_x86.cpp
@@ -53,14 +120,16 @@
static Thread* _sp_map[1UL << (SP_BITLENGTH - PAGE_SHIFT)];
public:
---- openjdk.orig/hotspot/src/os_cpu/linux_aarch64/vm/os_linux_aarch64.cpp
-+++ openjdk/hotspot/src/os_cpu/linux_aarch64/vm/os_linux_aarch64.cpp
-@@ -75,7 +75,7 @@
- # include <pwd.h>
- # include <poll.h>
- # include <ucontext.h>
--# include <fpu_control.h>
-+# include <linux/types.h> /* provides __u64 */
-
- #ifdef BUILTIN_SIM
- #define REG_SP REG_RSP
+diff --git openjdk/hotspot/src/share/vm/utilities/globalDefinitions_gcc.hpp openjdk/hotspot/src/share/vm/utilities/globalDefinitions_gcc.hpp
+index efa0b4e..6df2302 100644
+--- openjdk/hotspot/src/share/vm/utilities/globalDefinitions_gcc.hpp
++++ openjdk/hotspot/src/share/vm/utilities/globalDefinitions_gcc.hpp
+@@ -235,7 +235,7 @@ inline int g_isnan(double f) { return isnand(f); }
+ #elif defined(__APPLE__)
+ inline int g_isnan(double f) { return isnan(f); }
+ #elif defined(LINUX) || defined(_ALLBSD_SOURCE)
+-inline int g_isnan(float f) { return isnanf(f); }
++inline int g_isnan(float f) { return isnan(f); }
+ inline int g_isnan(double f) { return isnan(f); }
+ #else
+ #error "missing platform-specific definition here"
diff --git a/community/openjdk8/icedtea-hotspot-uclibc-fixes.patch b/community/openjdk8/icedtea-hotspot-uclibc-fixes.patch
deleted file mode 100644
index 1c1d8227600..00000000000
--- a/community/openjdk8/icedtea-hotspot-uclibc-fixes.patch
+++ /dev/null
@@ -1,93 +0,0 @@
---- openjdk.orig/hotspot/src/os/linux/vm/os_linux.cpp
-+++ openjdk/hotspot/src/os/linux/vm/os_linux.cpp
-@@ -112,7 +112,6 @@
- # include <string.h>
- # include <syscall.h>
- # include <sys/sysinfo.h>
--# include <gnu/libc-version.h>
- # include <sys/ipc.h>
- # include <sys/shm.h>
- # include <link.h>
-@@ -632,6 +631,13 @@
- // detecting pthread library
-
- void os::Linux::libpthread_init() {
-+#if 1
-+ // Hard code Alpine Linux supported uclibc/musl compatible settings
-+ os::Linux::set_glibc_version("glibc 2.9");
-+ os::Linux::set_libpthread_version("NPTL");
-+ os::Linux::set_is_NPTL();
-+ os::Linux::set_is_floating_stack();
-+#else
- // Save glibc and pthread version strings. Note that _CS_GNU_LIBC_VERSION
- // and _CS_GNU_LIBPTHREAD_VERSION are supported in glibc >= 2.3.2. Use a
- // generic name for earlier versions.
-@@ -690,6 +696,7 @@
- if (os::Linux::is_NPTL() || os::Linux::supports_variable_stack_size()) {
- os::Linux::set_is_floating_stack();
- }
-+#endif
- }
-
- /////////////////////////////////////////////////////////////////////////////
-@@ -2951,11 +2958,7 @@
- // If we are running with earlier version, which did not have symbol versions,
- // we should use the base version.
- void* os::Linux::libnuma_dlsym(void* handle, const char *name) {
-- void *f = dlvsym(handle, name, "libnuma_1.1");
-- if (f == NULL) {
-- f = dlsym(handle, name);
-- }
-- return f;
-+ return dlsym(handle, name);
- }
-
- bool os::Linux::libnuma_init() {
-@@ -5312,7 +5315,25 @@
- // Linux doesn't yet have a (official) notion of processor sets,
- // so just return the system wide load average.
- int os::loadavg(double loadavg[], int nelem) {
-+#ifdef __UCLIBC__
-+ FILE *LOADAVG;
-+ double avg[3] = { 0.0, 0.0, 0.0 };
-+ int i, res = -1;;
-+
-+ if ((LOADAVG = fopen("/proc/loadavg", "r"))) {
-+ fscanf(LOADAVG, "%lf %lf %lf", &avg[0], &avg[1], &avg[2]);
-+ res = 0;
-+ fclose(LOADAVG);
-+ }
-+
-+ for (i = 0; (i < nelem) && (i < 3); i++) {
-+ loadavg[i] = avg[i];
-+ }
-+
-+ return res;
-+#else
- return ::getloadavg(loadavg, nelem);
-+#endif
- }
-
- void os::pause() {
---- openjdk.orig/hotspot/src/share/vm/utilities/globalDefinitions_gcc.hpp
-+++ openjdk/hotspot/src/share/vm/utilities/globalDefinitions_gcc.hpp
-@@ -253,7 +253,7 @@
- #elif defined(__APPLE__)
- inline int g_isnan(double f) { return isnan(f); }
- #elif defined(LINUX) || defined(_ALLBSD_SOURCE)
--inline int g_isnan(float f) { return isnanf(f); }
-+inline int g_isnan(float f) { return isnan(f); }
- inline int g_isnan(double f) { return isnan(f); }
- #else
- #error "missing platform-specific definition here"
-@@ -267,8 +267,8 @@
-
- // Checking for finiteness
-
--inline int g_isfinite(jfloat f) { return finite(f); }
--inline int g_isfinite(jdouble f) { return finite(f); }
-+inline int g_isfinite(jfloat f) { return isfinite(f); }
-+inline int g_isfinite(jdouble f) { return isfinite(f); }
-
-
- // Wide characters