aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-03-28 09:24:32 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-03-28 09:24:37 +0000
commit8b57a73a0577e12b05fa9bf71d7376a598e69535 (patch)
tree7e4bc3c9b82bd5657990efa3e3d51a7a586c8119 /community
parentb4b5d963e58ba35f3b25265acb8ef00dd5d0e1e2 (diff)
community/py-netifaces: moved from testing
Diffstat (limited to 'community')
-rw-r--r--community/py-netifaces/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/community/py-netifaces/APKBUILD b/community/py-netifaces/APKBUILD
new file mode 100644
index 00000000000..b8797fd6ec0
--- /dev/null
+++ b/community/py-netifaces/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-netifaces
+_pkgname=netifaces
+pkgver=0.10.5
+pkgrel=3
+pkgdesc="Portable module to access network interface information in Python"
+url="http://alastairs-place.net/netifaces/"
+arch="all"
+license="MIT"
+makedepends="python2-dev python3-dev py-setuptools linux-headers"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="736bb985b444e78676dc10533a7597e750cadf41033196c4be49c4f33e91d46eba33a1f485e07e9f70aec2170c958564a6f54bbaa1ab193bfaca04b1fb07b3a1 netifaces-0.10.5.tar.gz"