aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2021-11-30 12:23:29 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2021-11-30 12:23:29 +0100
commit90d9b3657d4e1cde1c460b9c9556dfdf4d443719 (patch)
tree582e91dddae75890e96eb823f656e4545e96d72e /community
parente2505001b626fe69cc53b02336fc4be78ff1fa73 (diff)
community/mpc: upgrade to 0.34
Diffstat (limited to 'community')
-rw-r--r--community/mpc/0001-doc-make-upload-target-dependency-on-rsync-optional.patch58
-rw-r--r--community/mpc/APKBUILD12
2 files changed, 66 insertions, 4 deletions
diff --git a/community/mpc/0001-doc-make-upload-target-dependency-on-rsync-optional.patch b/community/mpc/0001-doc-make-upload-target-dependency-on-rsync-optional.patch
new file mode 100644
index 00000000000..a3b05e1a17e
--- /dev/null
+++ b/community/mpc/0001-doc-make-upload-target-dependency-on-rsync-optional.patch
@@ -0,0 +1,58 @@
+From b656ca4b6c2a0d5b6cebd7f7daa679352f664e0e Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
+Date: Tue, 30 Nov 2021 02:53:23 +0100
+Subject: [PATCH] doc: make upload target dependency on rsync optional
+
+Currently, rsync is an unconditional dependency and checked during
+`meson configure`. As such, the build will fail if rsync is not
+installed which is probably not what was intended here.
+
+From the meson documentation:
+
+ Meson will automatically insert the appropriate dependencies on
+ targets and files listed in this keyword [the command] argument.
+
+This commit fixes the unconditional dependency on rsync with an explicit
+find_program invocation with `required: false`. Also wrap the
+custom_target in an if statement since it is not allowed to use
+non-found external programs in `command`.
+---
+ doc/meson.build | 25 ++++++++++++++-----------
+ 1 file changed, 14 insertions(+), 11 deletions(-)
+
+diff --git a/doc/meson.build b/doc/meson.build
+index f9475da..62529f8 100644
+--- a/doc/meson.build
++++ b/doc/meson.build
+@@ -8,17 +8,20 @@ sphinx_output = custom_target(
+ install_dir: join_paths(get_option('datadir'), 'doc', meson.project_name()),
+ )
+
+-custom_target(
+- 'upload',
+- input: sphinx_output,
+- output: 'upload',
+- build_always_stale: true,
+- command: [
+- 'rsync', '-vpruz', '--delete', '@INPUT@',
+- 'www.musicpd.org:/var/www/mpd/doc/mpc/',
+- '--chmod=a+rX',
+- ],
+-)
++rsync = find_program('rsync', required: false)
++if rsync.found()
++ custom_target(
++ 'upload',
++ input: sphinx_output,
++ output: 'upload',
++ build_always_stale: true,
++ command: [
++ rsync, '-vpruz', '--delete', '@INPUT@',
++ 'www.musicpd.org:/var/www/mpd/doc/mpc/',
++ '--chmod=a+rX',
++ ],
++ )
++endif
+
+ custom_target(
+ 'Manpage documentation',
diff --git a/community/mpc/APKBUILD b/community/mpc/APKBUILD
index 9461bf7dff3..5ddda925b2c 100644
--- a/community/mpc/APKBUILD
+++ b/community/mpc/APKBUILD
@@ -1,15 +1,16 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mpc
-pkgver=0.33
-pkgrel=2
+pkgver=0.34
+pkgrel=0
pkgdesc="Minimalist command line interface to MPD"
url="https://www.musicpd.org/clients/mpc/"
arch="all"
license="GPL-2.0-or-later"
makedepends="libmpdclient-dev py3-sphinx meson check-dev"
subpackages="$pkgname-bash-completion:bashcomp:noarch $pkgname-doc"
-source="https://www.musicpd.org/download/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+source="https://www.musicpd.org/download/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
+ 0001-doc-make-upload-target-dependency-on-rsync-optional.patch"
build() {
abuild-meson \
@@ -36,4 +37,7 @@ bashcomp() {
"$subpkgdir"/usr/share/bash-completion/completions/$pkgname
}
-sha512sums="d3247dfb54ac3c95caf5666088968a952b33eb7e8f941bca4f3715603839cf5a1bc5300488c78fdce6e38f612b243f2252ea682b8d0fec9f230acd760bf3560c mpc-0.33.tar.xz"
+sha512sums="
+d43d5547134ffb24f2a2972882f6e264c1011a94d1033369d329487f59414d32d9842835afdd05da96fd8ed28f823d2ae2f46d8d8d24b68f3695badca2a9bbb2 mpc-0.34.tar.xz
+60c00c5ab212d453f879ac391d58be4d0fb7ea97dd974ac2369463bebc2e3a05f7176f3c89328b432d84382ecee9c8e9d67e16a0eb50219aeca53675d6a5988f 0001-doc-make-upload-target-dependency-on-rsync-optional.patch
+"