aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorinfo@mobile-stream.com <info@mobile-stream.com>2018-11-28 07:01:20 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-30 13:10:00 +0000
commit955c1fb83c58dcd07e633ced57578a783201f5ed (patch)
treeb1a56333ef4aa2c7e39bba742bf8067de6d1cfc7 /community
parent529f7d454f589f120f2bcc1c2fd5eeb42afe324f (diff)
community/drawterm: fix build on mips*
Do not bump pkgrel since only strictly mips-specific files were changed and no previously built mips* apks exist.
Diffstat (limited to 'community')
-rw-r--r--community/drawterm/APKBUILD2
-rw-r--r--community/drawterm/fix-mips-build.patch37
2 files changed, 39 insertions, 0 deletions
diff --git a/community/drawterm/APKBUILD b/community/drawterm/APKBUILD
index 6ab65eb41b0..2e54ce8fed1 100644
--- a/community/drawterm/APKBUILD
+++ b/community/drawterm/APKBUILD
@@ -13,6 +13,7 @@ makedepends="linux-headers libx11-dev libxt-dev"
install=""
subpackages="$pkgname-dbg"
source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
+ fix-mips-build.patch
fix-off-by-one.patch
respect-env.patch"
@@ -60,5 +61,6 @@ package() {
}
sha512sums="fec2895bd01940cd91ed6c4b73fd13ec6a55c5a5b2241f48430a73af44e6e4c649819a2ee9feee1880d4bf27ab007a229c6b5170039b73f1f19f8b0e6d04c510 drawterm-20170119.tar.gz
+45f4fa7dbc509748c06e292641bd4e30ec097c1e1d81bbf6f43e0d8c6b93a14a1f51cf683f2aba4a5945306d822bcf26ce39129169158217eca205015fed7967 fix-mips-build.patch
dc57264470e2ab583c7dfbb6451b9fcea47e37a24bdeb7e512ab50a0321f086b471dbe08b2d13514c7842e084f5fdf078f917a19e62bd6aaceb2e199e8169374 fix-off-by-one.patch
be42c27a550b49f13fa26cdd698fb4d8387d989141cae1a3671deceb82b9286c9f73772ec9731698c7ecef69949381f9eda8af1dc1d9957fa373752e52f809bb respect-env.patch"
diff --git a/community/drawterm/fix-mips-build.patch b/community/drawterm/fix-mips-build.patch
new file mode 100644
index 00000000000..8efd8016262
--- /dev/null
+++ b/community/drawterm/fix-mips-build.patch
@@ -0,0 +1,37 @@
+--- a/posix-mips/Makefile
++++ b/posix-mips/Makefile
+@@ -15,4 +15,4 @@
+
+ tas.$O: tas.s
+ ln -sf tas.s tas.S
+- $(CC) -c -o tas.$O -mips3 tas.S
++ $(CC) -c -o tas.$O tas.S
+--- a/posix-mips/tas.s
++++ b/posix-mips/tas.s
+@@ -1,19 +1,17 @@
+-#include <machine/regdef.h>
+-
+ .globl tas
+ .ent tas 2
+
+ tas:
+ .set noreorder
+ 1:
+- ori t1, zero, 12345 /* t1 = 12345 */
+- ll t0, (a0) /* t0 = *a0 */
+- sc t1, (a0) /* *a0 = t1 if *a0 hasn't changed; t1=success */
+- beq t1, zero, 1b /* repeat if *a0 did change */
+- nop
++ li $t1, 12345 /* t1 = 12345 */
++ ll $t0, ($a0) /* t0 = *a0 */
++ sc $t1, ($a0) /* *a0 = t1 if *a0 hasn't changed; t1=success */
++ beqz $t1, 1b /* repeat if *a0 did change */
++ nop
+
+- j $31 /* return */
+- or v0, t0, zero /* set return value on way out */
++ jr $ra /* return */
++ move $v0, $t0 /* set return value on way out */
+
+ .set reorder
+ .end tas