aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-12-26 15:07:35 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2018-12-26 15:35:07 +0100
commit981e24ddb68fe148e8c7f8a1627820c2b5142421 (patch)
tree0e0f0d1de234faacc76cbb4670c02f1b5d91b678 /community
parent54264b95671083a5a543583045f0dc1c0a735791 (diff)
community/z3: upgrade to 4.8.4
Both patches should no longer be needed: immintrin-i386-only.patch: has been applied upstream [0]. fix-ppc64le-ptr-size.patch: checks for __LP64__ now [1] which covers our cases. [0]: https://github.com/Z3Prover/z3/commit/a3ece29628501b405cb065f535ab0a003672fec0 [1]: https://github.com/Z3Prover/z3/commit/51a947b73d9d597029c30c62fe8d59d013a48f3c
Diffstat (limited to 'community')
-rw-r--r--community/z3/APKBUILD12
-rw-r--r--community/z3/fix-ppc64le-ptr-size.patch11
-rw-r--r--community/z3/immintrin-i386-only.patch12
3 files changed, 4 insertions, 31 deletions
diff --git a/community/z3/APKBUILD b/community/z3/APKBUILD
index b851732f76a..f085b6122ff 100644
--- a/community/z3/APKBUILD
+++ b/community/z3/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=z3
-pkgver=4.8.3
-pkgrel=1
+pkgver=4.8.4
+pkgrel=0
pkgdesc="Theorem prover from Microsoft Research"
url="https://github.com/Z3Prover/z3"
arch="all !s390x !aarch64"
@@ -11,9 +11,7 @@ depends=""
makedepends="cmake python3"
install=""
subpackages="$pkgname-dev py3-$pkgname:py3:noarch"
-source="https://github.com/Z3Prover/$pkgname/archive/$pkgname-$pkgver.tar.gz
- immintrin-i386-only.patch
- fix-ppc64le-ptr-size.patch"
+source="https://github.com/Z3Prover/$pkgname/archive/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgname-$pkgver"
build() {
@@ -55,6 +53,4 @@ py3() {
"$subpkgdir"/usr/lib/
}
-sha512sums="34a2dca0083ed469fdaf5ac062dda26248633245607ddd9ef90629c5f76ae30f87bfa4191c04ba9be7a617bf182a1bd00b59fd2274699e12ece69b86088c8044 z3-4.8.3.tar.gz
-4d9059b8a4c2d2217abdebc2d8e118adc37594b71e056ede488e2fe314c243dbb35efc413120ff110d54723e780b4e2daedefbc57e8a140c3bddb3e03630431c immintrin-i386-only.patch
-3d019959a104b5fd5f72eeb3738cacbdb145764ad4844eeb2539b36fa3a8228ffa062a0899465d4881b6c226301aa09b129ef06a798744b2eec9f943e0d9d366 fix-ppc64le-ptr-size.patch"
+sha512sums="4660ba6ab33a6345b2e8396c332d4afcfc73eda66ceb2595a39f152df4d62a9ea0f349b0f9212389ba84ecba6bdae6ad9b62b376ba44dc4d9c74f80d7a818bf4 z3-4.8.4.tar.gz"
diff --git a/community/z3/fix-ppc64le-ptr-size.patch b/community/z3/fix-ppc64le-ptr-size.patch
deleted file mode 100644
index cdf5e2156f6..00000000000
--- a/community/z3/fix-ppc64le-ptr-size.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/util/machine.h
-+++ b/src/util/machine.h
-@@ -20,7 +20,7 @@
- #ifndef MACHINE_H_
- #define MACHINE_H_
-
--#ifdef _AMD64_
-+#if defined(_AMD64_) || defined(__powerpc64__)
- #define PTR_ALIGNMENT 3
- #else
- #define PTR_ALIGNMENT 2
diff --git a/community/z3/immintrin-i386-only.patch b/community/z3/immintrin-i386-only.patch
deleted file mode 100644
index d4be4d80435..00000000000
--- a/community/z3/immintrin-i386-only.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/src/util/mpz.cpp
-+++ b/src/util/mpz.cpp
-@@ -30,7 +30,9 @@
- #else
- #error No multi-precision library selected.
- #endif
-+#if defined(__i386__) || defined(__amd64__)
- #include <immintrin.h>
-+#endif
-
- // Available GCD algorithms
- // #define EUCLID_GCD