aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2022-07-01 18:27:34 +0200
committerMichał Polański <michal@polanski.me>2022-07-01 18:27:34 +0200
commit9c020cdd7700aca09a79daa4f06b365e2fb1f437 (patch)
tree5f22f3dda009c7456653d2f623a66491f9b723f1 /community
parent5fe802715e727307b2845a1eefa1153c5f4267e1 (diff)
community/borgmatic: upgrade to 1.6.5
Diffstat (limited to 'community')
-rw-r--r--community/borgmatic/APKBUILD9
-rw-r--r--community/borgmatic/python3.patch11
2 files changed, 17 insertions, 3 deletions
diff --git a/community/borgmatic/APKBUILD b/community/borgmatic/APKBUILD
index 02a02224181..7afd966b2f7 100644
--- a/community/borgmatic/APKBUILD
+++ b/community/borgmatic/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=borgmatic
-pkgver=1.6.4
+pkgver=1.6.5
pkgrel=0
pkgdesc="Simple, configuration-driven backup software for servers and workstations"
url="https://torsion.org/borgmatic/"
@@ -21,7 +21,9 @@ checkdepends="
py3-pytest-cov
py3-flexmock
"
-source="$pkgname-$pkgver.tar.gz::https://projects.torsion.org/borgmatic-collective/borgmatic/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://projects.torsion.org/borgmatic-collective/borgmatic/archive/$pkgver.tar.gz
+ python3.patch
+ "
builddir="$srcdir/borgmatic"
build() {
@@ -38,5 +40,6 @@ package() {
}
sha512sums="
-cae4008cd03dad1b25a69322c8c6ae2b0c1a6f498c68a97fe68303a466c2d47ac98527f08c482421fc80507d34840e7ddc37d4763ada5d332a4ba030db794b5b borgmatic-1.6.4.tar.gz
+139fb7382e00f8285ed73cf6f716053bf7fa877a37af7ba98b7c48dc502d07d58c838f416a017dee6bc356a2c7913dc4339efcf234a0cecd7d6775f8f43388c2 borgmatic-1.6.5.tar.gz
+c4561ec75f486f75121f18039e42b166ed7eac4f3a6a2e821410ec0b8f0d1a48f1e5155393d8b735b6554efcf9cfc8ff163bc64b262b0239f86a03ec59ab6652 python3.patch
"
diff --git a/community/borgmatic/python3.patch b/community/borgmatic/python3.patch
new file mode 100644
index 00000000000..86eea9c0632
--- /dev/null
+++ b/community/borgmatic/python3.patch
@@ -0,0 +1,11 @@
+--- a/tests/integration/test_execute.py
++++ b/tests/integration/test_execute.py
+@@ -80,7 +80,7 @@ def test_log_outputs_logs_multiline_error_output():
+ flexmock(module).should_receive('command_for_process').and_return('grep')
+
+ process = subprocess.Popen(
+- ['python', '-c', 'foopydoo'], stdout=subprocess.PIPE, stderr=subprocess.STDOUT
++ ['python3', '-c', 'foopydoo'], stdout=subprocess.PIPE, stderr=subprocess.STDOUT
+ )
+ flexmock(module).should_receive('output_buffer_for_process').and_return(process.stdout)
+ flexmock(module.logger).should_call('log').at_least().times(3)