aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-10-04 14:23:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-10-04 14:25:33 +0000
commita7e6d049969a6ad0b8f86bad49a2f846007217a5 (patch)
treed7558ec7787537695d514760e99babcef5f202fb /community
parent0e62852519eb49144b33213289fac2afcfe964ae (diff)
community/py-numpy: fix undefined functions on s390x
backport fix from upstream: https://github.com/numpy/numpy/pull/11711 This fixes build of py-scipy on s390x
Diffstat (limited to 'community')
-rw-r--r--community/py-numpy/APKBUILD4
-rw-r--r--community/py-numpy/fix-undefined-functions-on-big-endian-systems.patch35
2 files changed, 38 insertions, 1 deletions
diff --git a/community/py-numpy/APKBUILD b/community/py-numpy/APKBUILD
index bebbd3e4fd8..0991a4b3801 100644
--- a/community/py-numpy/APKBUILD
+++ b/community/py-numpy/APKBUILD
@@ -5,7 +5,7 @@
pkgname=py-numpy
_pkgname=numpy
pkgver=1.15.0
-pkgrel=0
+pkgrel=1
pkgdesc="Scientific tools for Python"
url="http://numpy.scipy.org/"
arch="all"
@@ -21,6 +21,7 @@ subpackages="$pkgname-dev
py2-$_pkgname:_py
py3-$_pkgname:_py"
source="https://github.com/numpy/numpy/releases/download/v$pkgver/$_pkgname-$pkgver.tar.gz
+ fix-undefined-functions-on-big-endian-systems.patch
site.cfg"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -102,4 +103,5 @@ _pylibdir() {
}
sha512sums="a1f0f2a2227ee2ea0a7c2c6676be1d50f1b67cc58f409b3b1094de50390294c23509f88a394a390c57d03c2d5785256c12d8534ad87f6719f0ec4ea574de7ed6 numpy-1.15.0.tar.gz
+e698115f59db8dd4e2f42a62f7e5df06beca84ac3e049f3aacfb2ecb976b82ac0a7660d1a0314266b8223cbd3518f7037d5b3e9edfc2816fcb6a3d900993cf20 fix-undefined-functions-on-big-endian-systems.patch
21ca8db304cbbf5949f07702f2a42bb5e5a0d641921e36649555a41b0e48f04e96f53760417823177ac27f6de24b2191e6e1d5f0eb393beafa29f7484e23284f site.cfg"
diff --git a/community/py-numpy/fix-undefined-functions-on-big-endian-systems.patch b/community/py-numpy/fix-undefined-functions-on-big-endian-systems.patch
new file mode 100644
index 00000000000..9a965c59ab9
--- /dev/null
+++ b/community/py-numpy/fix-undefined-functions-on-big-endian-systems.patch
@@ -0,0 +1,35 @@
+From ec843c7008b3d89e6f6023b88ac0f1d02e39be17 Mon Sep 17 00:00:00 2001
+From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
+Date: Sat, 11 Aug 2018 02:45:01 -0400
+Subject: [PATCH] BUG: Fix undefined functions on big-endian systems.
+
+Both these functions are used by `Dragon4_PrintFloat_IEEE_binary128`,
+which was recently made available on big-endian systems without these
+in #11568.
+---
+ numpy/core/src/multiarray/dragon4.c | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/numpy/core/src/multiarray/dragon4.c b/numpy/core/src/multiarray/dragon4.c
+index abbf05220b1..2e599136efc 100644
+--- a/numpy/core/src/multiarray/dragon4.c
++++ b/numpy/core/src/multiarray/dragon4.c
+@@ -114,7 +114,7 @@ LogBase2_64(npy_uint64 val)
+ return LogBase2_32((npy_uint32)val);
+ }
+
+-#if defined(HAVE_LDOUBLE_IEEE_QUAD_LE)
++#if defined(HAVE_LDOUBLE_IEEE_QUAD_LE) || defined(HAVE_LDOUBLE_IEEE_QUAD_BE)
+ static npy_uint32
+ LogBase2_128(npy_uint64 hi, npy_uint64 lo)
+ {
+@@ -217,7 +217,8 @@ BigInt_Set_uint64(BigInt *i, npy_uint64 val)
+
+ #if (defined(HAVE_LDOUBLE_IBM_DOUBLE_DOUBLE_LE) || \
+ defined(HAVE_LDOUBLE_IBM_DOUBLE_DOUBLE_BE) || \
+- defined(HAVE_LDOUBLE_IEEE_QUAD_LE))
++ defined(HAVE_LDOUBLE_IEEE_QUAD_LE) || \
++ defined(HAVE_LDOUBLE_IEEE_QUAD_BE))
+ static void
+ BigInt_Set_2x_uint64(BigInt *i, npy_uint64 hi, npy_uint64 lo)
+ {