aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-31 23:09:09 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-01 03:01:30 +0000
commitae13094fa7e842d521d5e2fb0208236386377d4b (patch)
treed576100a65884f51dc032e8c047f033ddb964e48 /community
parent17d2b8fd81c04832df80f8b63a434c2d79140361 (diff)
community/ubridge: upgrade to 0.9.18
Diffstat (limited to 'community')
-rw-r--r--community/ubridge/APKBUILD22
1 files changed, 8 insertions, 14 deletions
diff --git a/community/ubridge/APKBUILD b/community/ubridge/APKBUILD
index 11de2157cb9..eae7faf6279 100644
--- a/community/ubridge/APKBUILD
+++ b/community/ubridge/APKBUILD
@@ -1,37 +1,31 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=ubridge
-pkgver=0.9.16
+pkgver=0.9.18
pkgrel=0
pkgdesc="Bridge for UDP tunnels, Ethernet, TAP and VMnet interfaces."
url="https://github.com/GNS3/ubridge"
arch="all"
-license="GPL-3.0"
+license="GPL-3.0-or-later"
makedepends="libpcap-dev linux-headers"
-subpackages="$pkgname-doc"
install="$pkgname.post-install $pkgname.post-upgrade"
-source="$pkgname-$pkgver.tar.gz::https://github.com/GNS3/$pkgname/archive/v$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/GNS3/ubridge/archive/v$pkgver.tar.gz
musl-fixes.patch"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
make
}
check() {
- cd "$builddir"
- ./ubridge -h > /dev/null
+ # This normally wouldn't be accepted but this is literally how upstream
+ # CI does it
+ ./ubridge -v
}
package() {
- cd "$builddir"
- install -Dm755 $srcdir/$pkgname-$pkgver/$pkgname $pkgdir/usr/bin/$pkgname
- install -dm755 $pkgdir/usr/share/doc/$pkgname
- install -m644 $srcdir/$pkgname-$pkgver/README.rst -t $pkgdir/usr/share/doc/$pkgname
- install -Dm644 $srcdir/$pkgname-$pkgver/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -Dm755 ubridge -t "$pkgdir"/usr/bin
}
-sha512sums="409b5705e178d0edda17f5a321bc28a4a03d417c59893228e022a88025a51e4d4f9a18e548ec71f1b36df24b204cfdf73bc2efb8fe9e39893d29c16b3695380c ubridge-0.9.16.tar.gz
+sha512sums="f2c9e9d0242f61363a3f4ce6f1acf4013245ff0854a7f64c96d6b8737bd3cc505a38aaf43a0928e2a5a88bcd39f786e00fab68748ad56770d18d713005750c60 ubridge-0.9.18.tar.gz
6922022e18e85ee7d2cb244ebde8beee307a216953da804cc495d691980818f0401528157a8b14cfed0fb85bab2b18c78f230d4b94941de47861bd40eaccd3a3 musl-fixes.patch"