aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-05 04:21:46 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-05 05:18:30 -0300
commitb22cacbdda86e649709ede272b5d66042df640c1 (patch)
tree62351fad04c69600e82a2f0e5354ef72bd3d92d3 /community
parente45a088063541b58f06be0212c89ac3490352468 (diff)
community/py3-mechanize: upgrade to 0.4.3
Diffstat (limited to 'community')
-rw-r--r--community/py3-mechanize/APKBUILD41
1 files changed, 10 insertions, 31 deletions
diff --git a/community/py3-mechanize/APKBUILD b/community/py3-mechanize/APKBUILD
index 98d4f7063c4..45fb0c521ea 100644
--- a/community/py3-mechanize/APKBUILD
+++ b/community/py3-mechanize/APKBUILD
@@ -1,49 +1,28 @@
# Contributor: Francesco Colista <francesco.colista@gmail.com>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-mechanize
+pkgname=py3-mechanize
_pkgname=mechanize
-pkgver=0.2.5
-pkgrel=2
+pkgver=0.4.3
+pkgrel=0
pkgdesc="Stateful programmatic web browsing in Python"
-url="http://wwwsearch.sourceforge.net/mechanize/"
+url="https://github.com/python-mechanize/mechanize"
arch="noarch"
-license="BSD ZPL"
-makedepends="python2-dev py-setuptools python3-dev"
-subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
-source="http://wwwsearch.sourceforge.net/$_pkgname/src/$_pkgname-$pkgver.tar.gz"
+license="BSD-3-Clause"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- python2 setup.py build
python3 setup.py build
}
check() {
- python2 setup.py check
python3 setup.py check
}
package() {
- mkdir -p "$pkgdir"
- install -Dm644 COPYING.txt ${pkgdir}/usr/share/licenses/custom/${pkgname}/COPYING.txt
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-_py() {
- local python=$1
- pkgdesc="$pkgdesc - $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-sha512sums="23de1d9a5fba63d76fd577889594dacf5412fb2fccb58908a10ab350a81dd16a7a31019d0b4a59a5ed4115320c7e3585c77eef88dcd80a88a9c3c2da3c28fa68 mechanize-0.2.5.tar.gz"
+sha512sums="892f264ab2743b8649fb4647c8399a5952db82446d8d22e8df2ad1160a1aa147eaca8b8704fe2467a83a6cd01d6f697eea3c5be94f33770bd7daeda4df6de2d6 mechanize-0.4.3.tar.gz"