aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2019-04-23 22:06:24 +0300
committerAndy Postnikov <apostnikov@gmail.com>2019-05-14 20:04:06 +0300
commitb4840bc3518a1aca7c6eb3b63c9ba4a46c4692ec (patch)
tree4f394cfa0b49b2605078929d83b283d213dd6e3e /community
parent1acad0a31388f16eaa2e31563891a1ed8a5a5f49 (diff)
community/nodejs-current: upgrade to 12.2.0
Diffstat (limited to 'community')
-rw-r--r--community/nodejs-current/APKBUILD8
-rw-r--r--community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch20
-rw-r--r--community/nodejs-current/link-with-libatomic-on-mips32.patch22
3 files changed, 22 insertions, 28 deletions
diff --git a/community/nodejs-current/APKBUILD b/community/nodejs-current/APKBUILD
index 7dd6a59e225..b46cfe0e410 100644
--- a/community/nodejs-current/APKBUILD
+++ b/community/nodejs-current/APKBUILD
@@ -20,7 +20,7 @@
#
pkgname=nodejs-current
# The current stable version, i.e. non-LTS.
-pkgver=11.14.0
+pkgver=12.2.0
pkgrel=0
pkgdesc="JavaScript runtime built on V8 engine - current stable version"
url="https://nodejs.org/"
@@ -93,6 +93,6 @@ package() {
rm "$pkgdir"/usr/bin/npm "$pkgdir"/usr/bin/npx
}
-sha512sums="6491ccdcc7c55df3bacaea35824d59c0a4f41e96cb5873ddd88916e75863f0bada1262dbf42daddc8a19f9d781b103a981c84baf2c6aa673dc33ddfe25c5e6e3 node-v11.14.0.tar.gz
-3697009ae7bf90e7a83da33eac915de9cb32680cafc8003e727540f98942312699e0ee2ebf3014dea15b1f4bcf93f983eec521ad86d75073664c64f5fdeea84d dont-run-gyp-files-for-bundled-deps.patch
-adba24239eb8ccb1d27664e9a8b2af0992e2b7b59d03d67bd18598bf0a266f1b572e312980face891f93fad0330488e2af1ab8f524c1798746adb64bed994831 link-with-libatomic-on-mips32.patch"
+sha512sums="d97a804e2b0190603eba25f10c2259b938223eb81977e0d41607c41dccdc2d4ce6a24e2700903737b011a9a9c998a0387cbc5db54419be9072b5e20ba2287491 node-v12.2.0.tar.gz
+7634ae88ec660867361e0d909f3bf038270524f8e399d8a5f46ce63cc0f21529bdf3165246da263f0a848fd10dd3a2c5877a04864f35bc4c77556d3ac4eb6196 dont-run-gyp-files-for-bundled-deps.patch
+9f60928b53447f9590c7065bcdbdd4065d10a06e8451531615791a3bd7d14f9114807e5446e0ec00e2cb7a11a277050345e34636b199db2979d7f022b31ffde4 link-with-libatomic-on-mips32.patch"
diff --git a/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch b/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch
index c140800a340..25cce3cbb2a 100644
--- a/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch
+++ b/community/nodejs-current/dont-run-gyp-files-for-bundled-deps.patch
@@ -9,18 +9,12 @@ Node.js 7.2.0
--- a/Makefile
+++ b/Makefile
-@@ -121,12 +121,12 @@ with-code-cache:
+@@ -116,7 +116,7 @@
+ echo "'test-code-cache' target is a noop"
- .PHONY: test-code-cache
- test-code-cache: with-code-cache
- $(PYTHON) tools/test.py $(PARALLEL_ARGS) --mode=$(BUILDTYPE_LOWER) code-cache
-
--out/Makefile: common.gypi deps/uv/uv.gyp deps/http_parser/http_parser.gyp \
-- deps/zlib/zlib.gyp deps/v8/gypfiles/toolchain.gypi \
-+out/Makefile: common.gypi deps/http_parser/http_parser.gyp \
-+ deps/v8/gypfiles/toolchain.gypi \
- deps/v8/gypfiles/features.gypi deps/v8/gypfiles/v8.gyp node.gyp \
- config.gypi
+ out/Makefile: config.gypi common.gypi node.gyp \
+- deps/uv/uv.gyp deps/http_parser/http_parser.gyp deps/zlib/zlib.gyp \
++ deps/http_parser/http_parser.gyp \
+ tools/v8_gypfiles/toolchain.gypi tools/v8_gypfiles/features.gypi \
+ tools/v8_gypfiles/inspector.gypi tools/v8_gypfiles/v8.gyp
$(PYTHON) tools/gyp_node.py -f make
-
- config.gypi: configure configure.py
diff --git a/community/nodejs-current/link-with-libatomic-on-mips32.patch b/community/nodejs-current/link-with-libatomic-on-mips32.patch
index 1210c69f701..21f9960d7bd 100644
--- a/community/nodejs-current/link-with-libatomic-on-mips32.patch
+++ b/community/nodejs-current/link-with-libatomic-on-mips32.patch
@@ -1,20 +1,20 @@
---- a/deps/v8/gypfiles/v8.gyp
-+++ b/deps/v8/gypfiles/v8.gyp
-@@ -2012,6 +2012,11 @@
+--- a/tools/v8_gypfiles/v8.gyp
++++ b/tools/v8_gypfiles/v8.gyp
+@@ -2460,6 +2460,11 @@
+ }, {
+ 'toolsets': ['target'],
}],
- ],
- 'conditions': [
+ [ 'host_arch=="mips" or host_arch=="mipsel"', {
+ 'link_settings': {
+ 'libraries': [ '-latomic' ],
+ },
+ }],
['component=="shared_library"', {
- 'defines': [
- 'BUILDING_V8_BASE_SHARED',
+ 'direct_dependent_settings': {
+ 'defines': [ 'USING_V8_PLATFORM_SHARED' ],
--- a/node.gyp
+++ b/node.gyp
-@@ -479,6 +479,11 @@
+@@ -315,6 +315,11 @@
'msvs_disabled_warnings!': [4244],
'conditions': [
@@ -23,6 +23,6 @@
+ 'libraries': [ '-latomic' ],
+ },
+ }],
- [ 'node_code_cache_path!=""', {
- 'sources': [ '<(node_code_cache_path)' ]
- }, {
+ [ 'node_intermediate_lib_type=="static_library" and '
+ 'node_shared=="true" and OS=="aix"', {
+ # For AIX, shared lib is linked by static lib and .exp. In the