aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-09-09 20:02:54 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2016-09-10 13:06:03 +0200
commitb4e07e66359089f8b24b86f88cf91ffc1cea8476 (patch)
treec56e86e9fd007499a4e62b6da42fcad52d947aa9 /community
parent06d68ffc47272a527849ab16f65f0e8df26aadaf (diff)
community/picocom: move from testing
Also claim maintainership.
Diffstat (limited to 'community')
-rw-r--r--community/picocom/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/picocom/APKBUILD b/community/picocom/APKBUILD
new file mode 100644
index 00000000000..383405201c9
--- /dev/null
+++ b/community/picocom/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=picocom
+pkgver=2.1
+pkgrel=1
+pkgdesc="Minimal dumb-terminal emulation program"
+url="https://github.com/npat-efault/picocom"
+arch="all"
+license="GPL2"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/npat-efault/${pkgname}/archive/${pkgver}.tar.gz"
+
+builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ make CFLAGS="$CFLAGS" LDFLAGS="$LDFLAGS" \
+ -C "$builddir" || return 1
+}
+
+package() {
+ install -Dm755 "$builddir"/$pkgname \
+ "$pkgdir"/usr/bin/$pkgname || return 1
+ install -Dm644 "$builddir"/$pkgname.1 \
+ "$pkgdir"/usr/share/man/man1/$pkgname.1 || return 1
+
+ local file=
+ for file in CONTRIBUTORS README.md TODO; do
+ install -Dm644 "$builddir"/$file \
+ "$pkgdir"/usr/share/doc/$pkgname/$file || return 1
+ done
+}
+
+md5sums="7cae1424c1279f0f13dee5dcb3de3f45 picocom-2.1.tar.gz"
+sha256sums="6b152fc5f816eaef6b86336a4cec7cf1496b7c712061e5aea5a36f143a0b09ed picocom-2.1.tar.gz"
+sha512sums="0df692118e3cfa27edd8ff9d5abbde8a9dc02fb015476ab1469337d616eb69411db125a967107276fb50bc58e7b9748429b9ded4943712a082a10827d595c03e picocom-2.1.tar.gz"