aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-06-09 17:27:53 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-06-10 15:41:45 +0000
commitbddff6bc51f0e18f9217a79ee354b86d08ed0072 (patch)
tree18c7cfb060d0838e493e31e441ed0847a646243d /community
parentcb60b3c8a54f9f20754f3e6e24f9d361342900aa (diff)
community/plasma-wayland-protocols: new aport
Diffstat (limited to 'community')
-rw-r--r--community/plasma-wayland-protocols/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/plasma-wayland-protocols/APKBUILD b/community/plasma-wayland-protocols/APKBUILD
new file mode 100644
index 00000000000..5655500fcf4
--- /dev/null
+++ b/community/plasma-wayland-protocols/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=plasma-wayland-protocols
+pkgver=1.0
+pkgrel=0
+pkgdesc="Plasma Specific Protocols for Wayland"
+arch="noarch !armhf" # armhf blocked by extra-cmake-modules
+url="https://www.kde.org/plasma-desktop/"
+license="GPL-2.0-or-later AND (GPL-2.0-only OR GPL-3.0-only) AND LGPL-2.1-only"
+makedepends="extra-cmake-modules"
+source="https://download.kde.org/stable/plasma-wayland-protocols/$pkgver/plasma-wayland-protocols-$pkgver.tar.xz"
+options="!check" # No tests
+
+build() {
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --build build --target install
+}
+sha512sums="30ecbf9fbf9de7ee1d323fb43b0f4a05586e0f7d2c4d510e2300828e7a6a16e8907d8d2a835d4ecbb2d4d532641ea722ff6572403f767e0ac878b7fdb0897b08 plasma-wayland-protocols-1.0.tar.xz"