aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-07-09 10:07:02 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-08-26 14:23:46 +0000
commitcf6112fd29513754f024e22964f12aa873adb398 (patch)
tree669917e3c902157a27764768e7f4efa1eb730ea9 /community
parent5671b3d67f87f1b4972553d67495cf3d1fd65261 (diff)
community/py3-fann2: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/py3-fann2/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/py3-fann2/APKBUILD b/community/py3-fann2/APKBUILD
new file mode 100644
index 00000000000..16c9c8f6f59
--- /dev/null
+++ b/community/py3-fann2/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-fann2
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="Python bindings for Fast Artificial Neural Networks 2.2.0"
+url="https://github.com/FutureLinkCorporation/fann2"
+arch="all"
+license="LGPL-2.1-only"
+depends="python3"
+makedepends="py3-setuptools fann-dev swig python3-dev"
+subpackages="$pkgname-dev"
+source="https://github.com/FutureLinkCorporation/fann2/archive/$pkgver/fann2-$pkgver.tar.gz"
+options="!check" # No tests
+builddir="$srcdir/fann2-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="6bdb661a6c48666e2d87edee9fa6c830af2fd73c8a4e3d93ef1411084a70aac27a87637e780e0c1f6c95e8ef5ae2b4c718a5d583fda1f9aeaf64490144ec9abe fann2-1.2.0.tar.gz"