aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2018-10-08 21:35:00 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2018-10-08 21:35:42 -0500
commitd8c154d8781368526e412df2360801e0a451c109 (patch)
tree54b4644ae792791d57cc6f71d17b778026b9ba4d /community
parent4a37223c57e2c0028b0b907e15738184859ef29a (diff)
community/dhcp-helper: new aport
used in production for a few months, just never got around to committing it
Diffstat (limited to 'community')
-rw-r--r--community/dhcp-helper/APKBUILD35
-rw-r--r--community/dhcp-helper/compile-only-once.patch13
-rw-r--r--community/dhcp-helper/dhcp-helper.confd2
-rw-r--r--community/dhcp-helper/dhcp-helper.initd18
4 files changed, 68 insertions, 0 deletions
diff --git a/community/dhcp-helper/APKBUILD b/community/dhcp-helper/APKBUILD
new file mode 100644
index 00000000000..c730f5fd4f9
--- /dev/null
+++ b/community/dhcp-helper/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=dhcp-helper
+pkgver=1.2
+pkgrel=0
+pkgdesc="DHCP relay server"
+url="http://www.thekelleys.org.uk/dhcp-helper/"
+arch="all"
+license="GPL-2.0-only OR GPL-3.0-only"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc $pkgname-openrc"
+source="http://www.thekelleys.org.uk/dhcp-helper/dhcp-helper-$pkgver.tar.gz
+ compile-only-once.patch
+ $pkgname.initd
+ $pkgname.confd"
+options="!check"
+
+build() {
+ cd "$builddir"
+ make PREFIX=/usr version="${pkgver}-r${pkgrel}"
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX=/usr version="${pkgver}-r${pkgrel}" MANDIR=/usr/share/man DESTDIR="$pkgdir" install
+
+ install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+sha512sums="2f81d729a261454aac8ae9b508d3f319155fc9bdb80b0822317f244ea20fa471ee214f1a1df284375612344751308998591c5e4ac742fd34d720db8e65306ba5 dhcp-helper-1.2.tar.gz
+1d80211ee0fa9c27261749924ee0d623da7d54d61103705cb421eed2ad84c6f87de119f470aeb3504144be0d553b773aecf552e53c5698110d8b3a36bfe9061a compile-only-once.patch
+241719be1136ceaca984ada662a8d57e4ed2c2d9b4fba1249796d79af50b40432bc6e479b6c815dee4ac133c8e83aca87fbd5df90ba28e97297ed0347ef7c0f7 dhcp-helper.initd
+0281a04898e8b63c37a159876fe7b27f47416a2b95701a3820f65b8bfc52ea56026c66cb875f1e44f1cac40a47a4ef53dc94d85de9bdaca032ef1a144c0f2884 dhcp-helper.confd"
diff --git a/community/dhcp-helper/compile-only-once.patch b/community/dhcp-helper/compile-only-once.patch
new file mode 100644
index 00000000000..c35c6746e6d
--- /dev/null
+++ b/community/dhcp-helper/compile-only-once.patch
@@ -0,0 +1,13 @@
+--- dhcp-helper-1.2.orig/Makefile
++++ dhcp-helper-1.2/Makefile
+@@ -5,7 +5,9 @@
+ CFLAGS?= -O2
+ version= $(shell ./get-version)
+
+-all: dhcp-helper.c
++all: dhcp-helper
++
++dhcp-helper: dhcp-helper.c
+ $(CC) $(CFLAGS) $(RPM_OPT_FLAGS) -DVERSION=\"$(version)\" -Wall -W dhcp-helper.c -o dhcp-helper
+
+ clean:
diff --git a/community/dhcp-helper/dhcp-helper.confd b/community/dhcp-helper/dhcp-helper.confd
new file mode 100644
index 00000000000..bb80f372c63
--- /dev/null
+++ b/community/dhcp-helper/dhcp-helper.confd
@@ -0,0 +1,2 @@
+# Specify options to dhcp-helper(8).
+ARGS=""
diff --git a/community/dhcp-helper/dhcp-helper.initd b/community/dhcp-helper/dhcp-helper.initd
new file mode 100644
index 00000000000..77a7f44ca9b
--- /dev/null
+++ b/community/dhcp-helper/dhcp-helper.initd
@@ -0,0 +1,18 @@
+#!/sbin/openrc-run
+supervisor=supervise-daemon
+description="DHCP relay agent"
+
+nice="0"
+pidfile="/run/dhcp-helper.sd.pid"
+supervise_daemon_args=""
+
+# the args are very site-specific, use dhcp-helper --help to find out what you need
+ARGS=""
+
+command="/usr/sbin/dhcp-helper"
+command_args="-n ${ARGS}"
+
+depend() {
+ use net
+ after logger firewall
+}