aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2019-06-11 06:06:29 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-06-11 06:06:29 +0000
commite24e2cbe89eb61205eee9dd280db54522f8e1d75 (patch)
tree2ee08b964d2c99d69db73c43ec23b64d5c4f51d0 /community
parent67da4c0bf23a7bccd0b39eea9e6ed55eab5ddae8 (diff)
community/py-sortedcontainers: moved from testing
Diffstat (limited to 'community')
-rw-r--r--community/py-sortedcontainers/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/community/py-sortedcontainers/APKBUILD b/community/py-sortedcontainers/APKBUILD
new file mode 100644
index 00000000000..473f8888760
--- /dev/null
+++ b/community/py-sortedcontainers/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: André Klitzing <aklitzing@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=py-sortedcontainers
+_pkgname=sortedcontainers
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Python library for sorting collections and containers"
+url="http://www.grantjenks.com/docs/sortedcontainers"
+arch="noarch"
+license="Apache-2.0"
+makedepends="py-setuptools python2-dev python3-dev"
+checkdepends="py-nose pytest"
+subpackages="py2-$_pkgname:_py2 py3-$_pkgname:_py3"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ nosetests-2.7
+ nosetests-$(python3 -c 'import sys; print("{}.{}".format(sys.version_info.major, sys.version_info.minor))')
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="6fe2b6e7d030b67aa990d62160079852feaee7828164eae03a6477dc1704863f6ed0daadb44dc919653c66996d51f833b5858351a8fd5ad28998f8010a8ca1a4 sortedcontainers-2.1.0.tar.gz"