aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-23 17:43:25 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-03-23 17:43:25 +0100
commite46952daad79585b51d76889b1f9e59b9ef47cb8 (patch)
tree4f88ab2aeec59afa284b9ebdaf739592b1228d11 /community
parent094caaad40412d29c82810b59ee053f165c0f5b9 (diff)
community/lua-resty-http: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/lua-resty-http/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/lua-resty-http/APKBUILD b/community/lua-resty-http/APKBUILD
new file mode 100644
index 00000000000..9763d297fda
--- /dev/null
+++ b/community/lua-resty-http/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=lua-resty-http
+pkgver=0.10
+pkgrel=0
+pkgdesc="Lua HTTP client cosocket driver for OpenResty / ngx_lua"
+url="https://github.com/pintsized/lua-resty-http"
+arch="noarch"
+license="BSD2"
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/pintsized/lua-resty-http/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+options="!check"
+
+_luaversions="5.1 5.2 5.3"
+for _v in $_luaversions; do
+ subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
+done
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_subpackage() {
+ local lver="${subpkgname:3:3}"
+ pkgdesc="$pkgdesc (Lua $lver)"
+ depends="lua$lver"
+ install_if="$pkgname=$pkgver-r$pkgrel lua$lver"
+
+ cd "$builddir"
+ make install DESTDIR="$subpkgdir" LUA_LIB_DIR="/usr/share/lua/$lver"
+}
+
+sha512sums="5ce79bd5e58c09418470fd588670b79610085b61571861c6c9fd71e716c6b599a426e4045431c0e8ab493b5b66d2f851251fc2b0aaed338433619ff3669aab05 lua-resty-http-0.10.tar.gz"