aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2019-02-12 01:52:26 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-03-12 21:25:31 +0000
commitf84364e92bf0bedebdc99b93aa5e0d709358e74e (patch)
tree43d09a1217f22e43ab1399facd41be6ce55f35c1 /community
parent7dea3f7ebeeb0cb818a85da9395bb10ee62ffb02 (diff)
community/py-execnet: moved from testing
Diffstat (limited to 'community')
-rw-r--r--community/py-execnet/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/community/py-execnet/APKBUILD b/community/py-execnet/APKBUILD
new file mode 100644
index 00000000000..bbb0b3f51e7
--- /dev/null
+++ b/community/py-execnet/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Dmitry Romanenko <dmitry@romanenko.in>
+# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
+pkgname=py-execnet
+_pkgname=execnet
+pkgver=1.5.0
+pkgrel=0
+pkgdesc="execnet: rapid multi-Python deployment"
+url="https://github.com/pytest-dev/execnet"
+arch="noarch"
+license="MIT"
+depends="py-apipkg"
+options="!check" # Tests are broken https://github.com/pytest-dev/execnet/issues/89
+checkdepends="pytest"
+makedepends="python2-dev python3-dev py-setuptools py-setuptools_scm"
+subpackages="py3-$_pkgname:_py3 py2-$_pkgname:_py2"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ mv $builddir/doc/example/conftest.py $builddir
+ python2 -m pytest
+ python3 -m pytest
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="ca2b571fafdf8f68b3cc7a04ee326e3255828d4cde28ead65d0cef325569c3a6dee09359e525152248038de65326ffc6b75c8362f53aa5c0b3f736eb596cb2d9 execnet-1.5.0.tar.gz"