summaryrefslogtreecommitdiffstats
path: root/core/busybox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-02-26 20:12:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-02-26 20:17:59 +0000
commit3db01d8fa384f13dab3b9b3a3efe97acf95f10e8 (patch)
tree12f28efaf34d73a72c9e53b99ba3e65e2049ad6e /core/busybox
parent4d5f0eae414bff6782179fbe71cbb0c163742356 (diff)
core/busybox: support for depmod -r
so we can build linux kernel
Diffstat (limited to 'core/busybox')
-rw-r--r--core/busybox/APKBUILD5
-rw-r--r--core/busybox/busybox-1.13.2-depmod2.patch21
2 files changed, 25 insertions, 1 deletions
diff --git a/core/busybox/APKBUILD b/core/busybox/APKBUILD
index 3de54578b40..523fdd8828c 100644
--- a/core/busybox/APKBUILD
+++ b/core/busybox/APKBUILD
@@ -1,6 +1,7 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.13.2
-pkgrel=4
+pkgrel=5
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
license=GPL-2
@@ -15,6 +16,7 @@ source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
busybox-1.13.2-modprobe-errormsg.patch
busybox-1.13.2-modprobe-speedup.patch
busybox-1.13.2-tar.patch
+ busybox-1.13.2-depmod2.patch
busyboxconfig"
build() {
@@ -45,4 +47,5 @@ a72d169e9545e26257032e0e367feb95 busybox-1.13.2-mdev.patch
a743ec04f378b8456a725c7270b0be8b busybox-1.13.2-modprobe-errormsg.patch
2120bc7d9fb4dcbbb94664c9fefa4c8a busybox-1.13.2-modprobe-speedup.patch
90d093817855bc63ad16fbb8524f80df busybox-1.13.2-tar.patch
+3c43008545e069749d2d653532e1feb3 busybox-1.13.2-depmod2.patch
7da47c98607834ca9c47a22bf3fe4b6e busyboxconfig"
diff --git a/core/busybox/busybox-1.13.2-depmod2.patch b/core/busybox/busybox-1.13.2-depmod2.patch
new file mode 100644
index 00000000000..8261fc88906
--- /dev/null
+++ b/core/busybox/busybox-1.13.2-depmod2.patch
@@ -0,0 +1,21 @@
+--- busybox-1.13.2/modutils/depmod.c.orig 2009-02-25 11:54:02.000000000 +0000
++++ busybox-1.13.2/modutils/depmod.c 2009-02-25 11:57:33.000000000 +0000
+@@ -36,7 +36,8 @@
+ ARG_b = (1<<2), /* base directory when modules are in staging area */
+ ARG_e = (1<<3), /* with -F, print unresolved symbols */
+ ARG_F = (1<<4), /* System.map that contains the symbols */
+- ARG_n = (1<<5) /* dry-run, print to stdout only */
++ ARG_n = (1<<5), /* dry-run, print to stdout only */
++ ARG_r = (1<<6) /* Compat dummy. Linux Makefile uses it */
+ };
+
+ static int FAST_FUNC parse_module(const char *fname, struct stat *sb,
+@@ -138,7 +139,7 @@
+ struct utsname uts;
+ int tmp;
+
+- getopt32(argv, "aAb:eF:n", &moddir_base, NULL);
++ getopt32(argv, "aAb:eF:nr", &moddir_base, NULL);
+ argv += optind;
+
+ /* goto modules location */