summaryrefslogtreecommitdiffstats
path: root/core/fakeroot
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2008-11-05 19:54:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2008-11-05 19:54:23 +0000
commit5bc219893b522bed577ad31d95361d9ca6d1eb56 (patch)
treee9c6f86b7bfcb22b387af25e52bc0c700f6c2af2 /core/fakeroot
parenta03848f1d518446f270742dc19f17cb5e6b47e83 (diff)
core/fakeroot: current busybox does not support kill -s
Diffstat (limited to 'core/fakeroot')
-rw-r--r--core/fakeroot/APKBUILD9
-rw-r--r--core/fakeroot/busybox-compat.patch23
-rw-r--r--core/fakeroot/getopt.patch11
3 files changed, 28 insertions, 15 deletions
diff --git a/core/fakeroot/APKBUILD b/core/fakeroot/APKBUILD
index f08e5d0c1ea..1304b3b935a 100644
--- a/core/fakeroot/APKBUILD
+++ b/core/fakeroot/APKBUILD
@@ -1,6 +1,6 @@
pkgname=fakeroot
pkgver=1.10.1
-pkgrel=0
+pkgrel=1
pkgdesc="Gives a fake root environment, useful for building packages as a non-privileged user"
license='GPL'
url="http://packages.debian.org/fakeroot"
@@ -8,13 +8,14 @@ depends='uclibc'
makedepends='binutils gcc make linux-headers uclibc-dev'
subpackages="dev doc"
source="http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_${pkgver}.tar.gz
- getopt.patch"
+ busybox-compat.patch"
build() {
cd $startdir/src/$pkgname-$pkgver
- patch -p1 < ../getopt.patch
+ patch -p1 < ../busybox-compat.patch
./configure --prefix=/usr #--libdir=/usr/lib/libfakeroot
make || return 1
make DESTDIR=$startdir/pkg install
}
-md5sums="052a1b5474b3681bc5f3167d2b3711a8 fakeroot_1.10.1.tar.gz"
+md5sums="052a1b5474b3681bc5f3167d2b3711a8 fakeroot_1.10.1.tar.gz
+ea7b7e3065090d72804cdf4719dd5832 busybox-compat.patch"
diff --git a/core/fakeroot/busybox-compat.patch b/core/fakeroot/busybox-compat.patch
new file mode 100644
index 00000000000..1d07d0d31a4
--- /dev/null
+++ b/core/fakeroot/busybox-compat.patch
@@ -0,0 +1,23 @@
+--- fakeroot-1.10.1.orig/scripts/fakeroot.in Wed Nov 5 19:48:00 2008
++++ fakeroot-1.10.1/scripts/fakeroot.in Wed Nov 5 19:49:12 2008
+@@ -28,7 +28,7 @@
+
+ libfound=no
+
+-GETOPTEST=`getopt --version`
++GETOPTEST=`getopt --version 2>/dev/null`
+ case $GETOPTEST in
+ getopt*) # GNU getopt
+ TEMP=`getopt -l lib: -l faked: -l unknown-is-real -l fd-base: -l version -l help -- +l:f:i:s:ub:vh "$@"`
+@@ -133,9 +133,9 @@
+ PID=`echo $KEY_PID|cut -d: -f2`
+
+ if [ "$WAITINTRAP" -eq 0 ]; then
+- trap "kill -s @signal@ $PID" EXIT INT
++ trap "kill -@signal@ $PID" EXIT INT
+ else
+- trap 'FAKEROOTKEY=$FAKEROOTKEY LD_LIBRARY_PATH="$PATHS" LD_PRELOAD="$LIB" /bin/ls -l / >/dev/null 2>&1; while kill -s @signal@ $PID 2>/dev/null; do sleep 0.1; done' EXIT INT
++ trap 'FAKEROOTKEY=$FAKEROOTKEY LD_LIBRARY_PATH="$PATHS" LD_PRELOAD="$LIB" /bin/ls -l / >/dev/null 2>&1; while kill -@signal@ $PID 2>/dev/null; do sleep 0.1; done' EXIT INT
+ fi
+
+ if test -z "$FAKEROOTKEY" || test -z "$PID"; then
diff --git a/core/fakeroot/getopt.patch b/core/fakeroot/getopt.patch
deleted file mode 100644
index 177e1ba9549..00000000000
--- a/core/fakeroot/getopt.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- fakeroot-1.10.1/scripts/fakeroot.in.orig Tue Nov 4 14:32:03 2008
-+++ fakeroot-1.10.1/scripts/fakeroot.in Tue Nov 4 14:32:16 2008
-@@ -28,7 +28,7 @@
-
- libfound=no
-
--GETOPTEST=`getopt --version`
-+GETOPTEST=`getopt --version 2>/dev/null`
- case $GETOPTEST in
- getopt*) # GNU getopt
- TEMP=`getopt -l lib: -l faked: -l unknown-is-real -l fd-base: -l version -l help -- +l:f:i:s:ub:vh "$@"`