summaryrefslogtreecommitdiffstats
path: root/core/file/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-04-13 09:51:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-04-13 09:51:34 +0000
commit0837a73950a2461c249c24e1d2ec5e8bdcdedf52 (patch)
treead859f315ab779188a18c7959d321579dfce0dd3 /core/file/APKBUILD
parent8afe14323eecd84ed146fe7afbe13176ba595fbd (diff)
core/file: upgrade to 5.00
disabled useless check for C++ while there
Diffstat (limited to 'core/file/APKBUILD')
-rw-r--r--core/file/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/core/file/APKBUILD b/core/file/APKBUILD
index a7fd0ffb286..50b9b8e6c4b 100644
--- a/core/file/APKBUILD
+++ b/core/file/APKBUILD
@@ -1,19 +1,22 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=file
-pkgver=4.26
-pkgrel=1
+pkgver=5.00
+pkgrel=0
pkgdesc="File type identification utility"
url="http://www.darwinsys.com/file/"
license="custom"
depends="uclibc zlib"
-source="ftp://ftp.astron.com/pub/file/file-4.26.tar.gz"
+source="ftp://ftp.astron.com/pub/file/file-$pkgver.tar.gz
+ nocxx.patch"
subpackages="$pkgname-dev $pkgname-doc"
build ()
{
- cd ${srcdir}/$pkgname-$pkgver;
- ./configure --prefix=/usr --datadir=/usr/share/misc;
- make || return 1;
- make DESTDIR=${pkgdir} install;
+ cd "$srcdir"/$pkgname-$pkgver
+ patch configure < ../nocxx.patch || return 1
+ ./configure --prefix=/usr --datadir=/usr/share/misc
+ make || return 1
+ make DESTDIR="$pkgdir" install
}
-md5sums="74cd5466416136da30a4e69f74dbc7a0 file-4.26.tar.gz"
+md5sums="fd0b4ce55a756151629e06eaa3411e0c file-5.00.tar.gz
+28513788ba4d556ccd538867dc6205ab nocxx.patch"