summaryrefslogtreecommitdiffstats
path: root/core/linux-headers
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2008-11-07 18:53:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2008-11-07 18:53:44 +0000
commit0b6720c3aecc93d710ddc7ab3eabdece17bd193d (patch)
tree99a8d4d26157a48ae429670d4d0c499ab27b2d21 /core/linux-headers
parent8b7a45374eb32bcf812b7996058a29fa47ad70b4 (diff)
core/linux-headers: new aport
Diffstat (limited to 'core/linux-headers')
-rw-r--r--core/linux-headers/APKBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/core/linux-headers/APKBUILD b/core/linux-headers/APKBUILD
new file mode 100644
index 00000000000..fe8b7f0e02a
--- /dev/null
+++ b/core/linux-headers/APKBUILD
@@ -0,0 +1,19 @@
+pkgname=linux-headers
+pkgver=2.6.27.4
+pkgrel=0
+pkgdesc="Linux system headers"
+url="http://kernel.org"
+license='GPL-2'
+makedepends="linux-sources perl"
+
+build() {
+ mkdir -p "$srcdir/$pkgname"
+ mkdir -p "$pkgdir/usr"
+ make -C /usr/src/linux-$pkgver headers_install \
+ INSTALL_HDR_PATH="$pkgdir/usr" \
+ O="$srcdir/$pkgname"
+
+ find "$pkgdir/usr" \( -name .install -o -name ..install.cmd \) -exec \
+ rm -f {} \;
+}
+