summaryrefslogtreecommitdiffstats
path: root/core/uclibc++
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-03 14:11:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-03 14:11:38 +0000
commit8f4e071eace60d167af432469077b16f93706878 (patch)
tree443e9c1e17be3ad3f7bb14e3eb6c15ee16585603 /core/uclibc++
parent6077702773cc1609495ac82f2057c22098829259 (diff)
core/uclibc++: fix associative_base
The patch found to make uclibc++ build with gcc-4.3.x broke associative_base this is an updated patch which only solves gcc-4.3 compiling. also renamed it so its more clear why its here.
Diffstat (limited to 'core/uclibc++')
-rw-r--r--core/uclibc++/APKBUILD6
-rw-r--r--core/uclibc++/uclibc++-gcc-4.3.patch (renamed from core/uclibc++/uclibc++.patch)42
2 files changed, 12 insertions, 36 deletions
diff --git a/core/uclibc++/APKBUILD b/core/uclibc++/APKBUILD
index b0769d37fc3..98f2d113880 100644
--- a/core/uclibc++/APKBUILD
+++ b/core/uclibc++/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=uclibc++
pkgver=0.2.2
-pkgrel=2
+pkgrel=3
pkgdesc="Embedded C++ library"
url="http://cxx.uclibc.org/"
license='GPL-2'
@@ -10,7 +10,7 @@ makedepends="g++"
subpackages="$pkgname-dev"
source="http://cxx.uclibc.org/src/uClibc++-$pkgver.tar.bz2
associative_base.patch
- uclibc++.patch
+ uclibc++-gcc-4.3.patch
uclibc++config
"
@@ -43,5 +43,5 @@ dev() {
md5sums="1ceef3209cca88be8f1bd9de99735954 uClibc++-0.2.2.tar.bz2
5689baa3f3bf8488c0a5d27a690d30fa associative_base.patch
-230125c74591ac9afb30fa5ea6efffb8 uclibc++.patch
+4c7b499e4697225378acef25f6364e9b uclibc++-gcc-4.3.patch
2f573c1e2a0c7a320ea4685cc3ce9e2a uclibc++config"
diff --git a/core/uclibc++/uclibc++.patch b/core/uclibc++/uclibc++-gcc-4.3.patch
index 402f25d5b73..37d45a5d5a8 100644
--- a/core/uclibc++/uclibc++.patch
+++ b/core/uclibc++/uclibc++-gcc-4.3.patch
@@ -1,14 +1,6 @@
---- a/include/associative_base Sun Jun 3 22:51:12 2007
-+++ b/include/associative_base Sun Jan 11 21:50:05 2009
-@@ -74,7 +74,7 @@
- typedef typename std::reverse_iterator<const_iterator> const_reverse_iterator;
-
-
-- explicit __base_associative(const Compare& comp, const Allocator& A, const key_type (*v_to_k)(const value_type))
-+ explicit __base_associative(const Compare& comp, const Allocator& A, key_type (*v_to_k)(const value_type))
- : c(comp), value_to_key(v_to_k) { }
- protected:
- __base_associative(const associative_type& x)
+diff -ru uClibc++-0.2.2.orig/include/associative_base uClibc++-0.2.2/include/associative_base
+--- uClibc++-0.2.2.orig/include/associative_base 2009-03-03 14:03:40.000000000 +0000
++++ uClibc++-0.2.2/include/associative_base 2009-03-03 14:03:52.000000000 +0000
@@ -318,7 +318,7 @@
typedef std::list<ValueType> listtype;
@@ -45,26 +37,9 @@
}
typename listtype::iterator base_iterator(){
return base_iter;
-@@ -498,7 +498,7 @@
- using base::operator==;
- using base::operator!=;
-
-- explicit __single_associative(const Compare& comp, const Allocator& A, const key_type (*v_to_k)(const value_type))
-+ explicit __single_associative(const Compare& comp, const Allocator& A, key_type (*v_to_k)(const value_type))
- : base(comp, A, v_to_k) { }
-
- template <class InputIterator> __single_associative(
-@@ -506,7 +506,7 @@
- InputIterator last,
- const Compare& comp,
- const Allocator& A,
-- const key_type (*v_to_k)(const value_type)
-+ key_type (*v_to_k)(const value_type)
- ) : base(comp, A, v_to_k) {
- insert(first, last);
- }
---- a/include/string Sun Jun 3 22:51:12 2007
-+++ b/include/string Sun Jan 11 21:50:18 2009
+diff -ru uClibc++-0.2.2.orig/include/string uClibc++-0.2.2/include/string
+--- uClibc++-0.2.2.orig/include/string 2009-03-03 14:03:40.000000000 +0000
++++ uClibc++-0.2.2/include/string 2009-03-03 14:03:52.000000000 +0000
@@ -1017,11 +1017,11 @@
template <> _UCXXEXPORT bool operator==(const string & lhs, const string & rhs);
@@ -79,8 +54,9 @@
template <> _UCXXEXPORT string operator+(const string & lhs, const char* rhs);
template <> _UCXXEXPORT string operator+(const char* lhs, const string & rhs);
---- a/src/string.cpp Sun Jun 3 22:51:13 2007
-+++ b/src/string.cpp Sun Jan 11 21:50:33 2009
+diff -ru uClibc++-0.2.2.orig/src/string.cpp uClibc++-0.2.2/src/string.cpp
+--- uClibc++-0.2.2.orig/src/string.cpp 2009-03-03 14:03:41.000000000 +0000
++++ uClibc++-0.2.2/src/string.cpp 2009-03-03 14:03:52.000000000 +0000
@@ -76,11 +76,11 @@
template _UCXXEXPORT bool operator==(const string & lhs, const string & rhs);