summaryrefslogtreecommitdiffstats
path: root/core
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-02 13:09:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-02 13:09:51 +0000
commit439bbcd25575f703552d5c0740b1019693ddd19a (patch)
treef931f26d3a3c86ea3a4a76ee956c112223870ad7 /core
parent3001e17e4cdc277eb38d7d5288715c0c9d6b1c22 (diff)
core/linux-grsec: add post install/upgrade scripts for initfs
we need to update initfs or system will not be bootable
Diffstat (limited to 'core')
-rw-r--r--core/linux-grsec/APKBUILD8
-rw-r--r--core/linux-grsec/linux-grsec.post-install7
l---------core/linux-grsec/linux-grsec.post-upgrade1
3 files changed, 14 insertions, 2 deletions
diff --git a/core/linux-grsec/APKBUILD b/core/linux-grsec/APKBUILD
index 74f8eb6fa6d..0c0c447ab49 100644
--- a/core/linux-grsec/APKBUILD
+++ b/core/linux-grsec/APKBUILD
@@ -4,11 +4,12 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=2.6.29.5
_kernver=2.6.29
-pkgrel=2
+pkgrel=3
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
makedepends="perl installkernel"
_config=${config:-kernelconfig}
+install="$pkgname.post-install $pkgname.post-upgrade"
source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-$pkgver.bz2
grsecurity-2.1.14-2.6.29.5-200906152045.patch
@@ -16,6 +17,7 @@ source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
0002-linux-2.6.28.5-ipgre-optimize-hash-lookup.patch
net-next-2.6.git-5ef12d98a19254ee5dc851bd83e214b43ec1f725.patch
$_config
+ $install
"
subpackages="$pkgname-dev"
license="GPL-2"
@@ -115,4 +117,6 @@ e2e49a250303720b31c4371905c105e3 grsecurity-2.1.14-2.6.29.5-200906152045.patch
7673b4521283ad41434a18ca18b16ad8 0001-linux-2.6.28.5-ipgre-strict-binding.patch
8f405c738b150c532c46eaad5390cca2 0002-linux-2.6.28.5-ipgre-optimize-hash-lookup.patch
ca05fd252783b82e01610e775cf56498 net-next-2.6.git-5ef12d98a19254ee5dc851bd83e214b43ec1f725.patch
-c9443dcc46eb70267b4cfe6a6694f637 kernelconfig"
+c9443dcc46eb70267b4cfe6a6694f637 kernelconfig
+2834240b15805b248ef2a973b1ad4416 linux-grsec.post-install
+2834240b15805b248ef2a973b1ad4416 linux-grsec.post-upgrade"
diff --git a/core/linux-grsec/linux-grsec.post-install b/core/linux-grsec/linux-grsec.post-install
new file mode 100644
index 00000000000..626046f64cf
--- /dev/null
+++ b/core/linux-grsec/linux-grsec.post-install
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+# strip pkgrel from version
+ver=${1%-r[0-9]}
+
+mkinitfs $ver-grsec
+
diff --git a/core/linux-grsec/linux-grsec.post-upgrade b/core/linux-grsec/linux-grsec.post-upgrade
new file mode 120000
index 00000000000..1e3bdc8536b
--- /dev/null
+++ b/core/linux-grsec/linux-grsec.post-upgrade
@@ -0,0 +1 @@
+linux-grsec.post-install \ No newline at end of file