aboutsummaryrefslogtreecommitdiffstats
path: root/extra/bzip2/bzip2-1.0.4-makefile-CFLAGS.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2008-12-06 22:46:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2008-12-06 22:46:23 +0000
commita3a7b9564e340ffe5c9c4535e1c45bcd92c26fba (patch)
tree4fe694c0f3cb6a30178745d526d5ce2c7b07b34d /extra/bzip2/bzip2-1.0.4-makefile-CFLAGS.patch
parent99e85705805ede623c460425820d0e8c47b48182 (diff)
extra/bzip2: new aport
Diffstat (limited to 'extra/bzip2/bzip2-1.0.4-makefile-CFLAGS.patch')
-rw-r--r--extra/bzip2/bzip2-1.0.4-makefile-CFLAGS.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/extra/bzip2/bzip2-1.0.4-makefile-CFLAGS.patch b/extra/bzip2/bzip2-1.0.4-makefile-CFLAGS.patch
new file mode 100644
index 00000000000..85a3c6af6c3
--- /dev/null
+++ b/extra/bzip2/bzip2-1.0.4-makefile-CFLAGS.patch
@@ -0,0 +1,25 @@
+--- a/Makefile
++++ b/Makefile
+@@ -18,10 +18,9 @@
+ CC=gcc
+ AR=ar
+ RANLIB=ranlib
+-LDFLAGS=
+
+ BIGFILES=-D_FILE_OFFSET_BITS=64
+-CFLAGS=-Wall -Winline -O2 -g $(BIGFILES)
++CFLAGS+=-Wall -Winline $(BIGFILES)
+
+ # Where you want it installed when you do 'make install'
+ PREFIX=/usr/local
+--- a/Makefile-libbz2_so
++++ b/Makefile-libbz2_so
+@@ -24,7 +24,7 @@
+ SHELL=/bin/sh
+ CC=gcc
+ BIGFILES=-D_FILE_OFFSET_BITS=64
+-CFLAGS=-fpic -fPIC -Wall -Winline -O2 -g $(BIGFILES)
++CFLAGS+=-fpic -fPIC -Wall -Winline $(BIGFILES)
+
+ OBJS= blocksort.o \
+ huffman.o \