aboutsummaryrefslogtreecommitdiffstats
path: root/extra/libnet/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-01-30 14:20:40 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-01-30 14:20:40 +0000
commitf88076368123d254e8086f1f6697f749ab290879 (patch)
tree2143bfe4d5b65a9444b791bd4e35d8908df4a797 /extra/libnet/APKBUILD
parent677254a4e83d90613365d24f36e4e1ce43fa08e5 (diff)
extra/libnet: new aport
Libnet is a high-level API (toolkit) allowing the application programmer to construct and inject network packets. http://www.packetfactory.net/libnet/
Diffstat (limited to 'extra/libnet/APKBUILD')
-rw-r--r--extra/libnet/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/extra/libnet/APKBUILD b/extra/libnet/APKBUILD
new file mode 100644
index 00000000000..e756acc0eca
--- /dev/null
+++ b/extra/libnet/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Mika Havela <mika.havela@gmail.com>
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=libnet
+pkgver=1.1.2.1
+pkgrel=0
+pkgdesc="A generic networking API that provides access to several protocols."
+url="http://www.packetfactory.net/libnet/"
+license="BSD"
+depends="uclibc"
+makedepends="autoconf automake libtool"
+subpackages="$pkgname-dev"
+source="http://www.packetfactory.net/libnet/dist/$pkgname-$pkgver.tar.gz
+ libnet-1.1.2.1-autotools.patch
+ libnet-1.1.2.1-fix-chksum.patch
+ "
+
+build() {
+ local i
+ cd "$srcdir/$pkgname"
+ for i in ../*.patch; do
+ msg "Applyting $i"
+ patch -p1 < $i || return 1
+ done
+
+ aclocal
+ libtoolize --force || return 1
+ autoconf && automake || return 1
+
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="be845c41170d72c7db524f3411b50256 libnet-1.1.2.1.tar.gz
+7e928170600bea8ed4a0d079b83c80ac libnet-1.1.2.1-autotools.patch
+668189bf87cda8daeaf250146bd88331 libnet-1.1.2.1-fix-chksum.patch"