summaryrefslogtreecommitdiffstats
path: root/extra/ntfs-3g
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-04-22 19:56:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-04-22 19:56:59 +0000
commit69858593b283ff6221de03816abb4a4504c9d112 (patch)
tree5c8083b79208ddac80167457a446d05159d2428c /extra/ntfs-3g
parent380e9da0b89f7123babd843dbd320f5276c01255 (diff)
extra/ntfs-3g: disable useless c++ check
Diffstat (limited to 'extra/ntfs-3g')
-rw-r--r--extra/ntfs-3g/APKBUILD8
-rw-r--r--extra/ntfs-3g/nocxx.patch15
2 files changed, 21 insertions, 2 deletions
diff --git a/extra/ntfs-3g/APKBUILD b/extra/ntfs-3g/APKBUILD
index a5be8c0a7a7..5575e696de1 100644
--- a/extra/ntfs-3g/APKBUILD
+++ b/extra/ntfs-3g/APKBUILD
@@ -1,4 +1,5 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ntfs-3g
pkgver=2009.4.4
pkgrel=0
@@ -8,10 +9,12 @@ license="GPL"
depends="uclibc"
makedepends=""
subpackages="$pkgname-doc $pkgname-dev"
-source="http://www.ntfs-3g.org/${pkgname}-${pkgver}.tgz"
+source="http://www.ntfs-3g.org/${pkgname}-${pkgver}.tgz
+ nocxx.patch"
build() {
cd "$srcdir/$pkgname-$pkgver"
+ patch configure < ../nocxx.patch || return 1
./configure --prefix=/usr \
--sysconfdir=/etc \
@@ -22,4 +25,5 @@ build() {
}
-md5sums="e0b5c170f088a8d82968f0a6b34d31da ntfs-3g-2009.4.4.tgz"
+md5sums="e0b5c170f088a8d82968f0a6b34d31da ntfs-3g-2009.4.4.tgz
+28513788ba4d556ccd538867dc6205ab nocxx.patch"
diff --git a/extra/ntfs-3g/nocxx.patch b/extra/ntfs-3g/nocxx.patch
new file mode 100644
index 00000000000..beb1ab9006b
--- /dev/null
+++ b/extra/ntfs-3g/nocxx.patch
@@ -0,0 +1,15 @@
+--- a/configure 2004-12-07 21:34:23.205172545 +0000
++++ b/configure 2004-12-07 21:37:17.726654782 +0000
+@@ -5148,10 +5148,8 @@
+ :
+ else
+ { { echo "$as_me:$LINENO: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&5
+-echo "$as_me: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&2;}
+- { (exit 1); exit 1; }; }
++See \`config.log' for more details." >&5;}
++ { echo "C++ sucks, ignoring ..." >&5; }; }
+ fi
+
+ ac_ext=cc