summaryrefslogtreecommitdiffstats
path: root/extra/php
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-14 09:33:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-14 09:33:24 +0000
commitd14cd7d422be2879f0ef3dc6c3b9b27ce75e09e7 (patch)
tree14eacf51e452846e80309cfabe468c343386263c /extra/php
parent323a28a1929c566f5caaca9e4e344a03d0cfab1c (diff)
extra/php: upgrade to 5.2.10, build against jpeg-7
Diffstat (limited to 'extra/php')
-rw-r--r--extra/php/APKBUILD302
1 files changed, 108 insertions, 194 deletions
diff --git a/extra/php/APKBUILD b/extra/php/APKBUILD
index a07bba0cda6..f1a36a24e9a 100644
--- a/extra/php/APKBUILD
+++ b/extra/php/APKBUILD
@@ -1,53 +1,92 @@
# Contributor: Carlo Landmeter <clandmeter at gmail>
-# Maintainer: Carlo Landmeter <clandmeter at gmail>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=php
-pkgver=5.2.9
+pkgver=5.2.10
pkgrel=0
pkgdesc="The PHP language runtime engine"
url="http://www.php.net/"
license="PHP-3"
-depends="uclibc pcre libxml2"
+depends=
makedepends="pcre-dev libxml2-dev libiconv-dev openssl-dev zlib-dev bzip2-dev
-curl-dev libpng-dev libjpeg-dev freetype-dev libmcrypt-dev mysql-dev sqlite-dev
-libtool libltdl postgresql-dev"
+ curl-dev libpng-dev jpeg-dev freetype-dev libmcrypt-dev mysql-dev
+ sqlite-dev libtool libltdl postgresql-dev"
subpackages="$pkgname-doc $pkgname-dev $pkgname-bcmath $pkgname-bz2
-$pkgname-calendar $pkgname-curl $pkgname-exif $pkgname-ftp $pkgname-gd
-$pkgname-iconv $pkgname-json $pkgname-mcrypt $pkgname-mime_magic
-$pkgname-mysql $pkgname-mysqli $pkgname-openssl $pkgname-pdo
-$pkgname-pdo_mysql $pkgname-pdo_sqlite $pkgname-posix $pkgname-session
-$pkgname-shmop $pkgname-soap $pkgname-sockets $pkgname-sqlite $pkgname-sysvmsg
-$pkgname-sysvsem $pkgname-sysvshm $pkgname-xmlrpc $pkgname-zip $pkgname-zlib
-$pkgname-postgresql $pkgname-pdo_pgsql"
+ $pkgname-calendar $pkgname-curl $pkgname-exif $pkgname-ftp $pkgname-gd
+ $pkgname-iconv $pkgname-json $pkgname-mcrypt $pkgname-mime_magic
+ $pkgname-mysql $pkgname-mysqli $pkgname-openssl $pkgname-pdo
+ $pkgname-pdo_mysql $pkgname-pdo_sqlite $pkgname-posix $pkgname-session
+ $pkgname-shmop $pkgname-soap $pkgname-sockets $pkgname-sqlite
+ $pkgname-sysvmsg $pkgname-sysvsem $pkgname-sysvshm $pkgname-xmlrpc
+ $pkgname-zip $pkgname-zlib $pkgname-postgresql $pkgname-pdo_pgsql"
source="http://www.php.net/distributions/${pkgname}-${pkgver}.tar.bz2"
build() {
cd "$srcdir/$pkgname-$pkgver"
- ./configure \
- --prefix=/usr --sysconfdir=/etc/php --with-layout=GNU \
- --with-config-file-path=/etc/php \
- --with-config-file-scan-dir=/etc/php/conf.d \
- --enable-inline-optimization --disable-debug --disable-rpath \
- --disable-static --enable-shared --mandir=/usr/share/man \
- --with-openssl=shared --with-zlib=shared --enable-bcmath=shared \
- --with-bz2=shared --enable-calendar=shared --with-curl=shared \
- --enable-exif=shared --enable-ftp=shared --with-gd=shared \
- --with-jpeg-dir=shared,/usr --with-png-dir=shared,/usr \
- --enable-gd-native-ttf --enable-mbstring=shared --with-mcrypt=shared \
- --with-mysql=shared --with-mysql-sock=/tmp/mysql.sock \
- --with-mysql=shared --with-mysqli=shared --with-pear=/usr/share/pear \
- --enable-pdo=shared --with-pdo-mysql=shared \
- --with-pdo-sqlite=shared,/usr --enable-fastcgi \
- --with-sqlite=shared --enable-sqlite-utf8 --enable-shmop=shared \
- --enable-soap=shared --enable-sysvmsg=shared --enable-sysvsem=shared \
- --enable-sysvshm=shared --enable-zip=shared --enable-posix=shared \
- --enable-sockets=shared --enable-xml --with-ttf=shared \
- --enable-session=shared --with-regex=php --with-pcre-regex=/usr \
- --enable-mbstring=all --enable-mbregex --enable-json=shared \
- --with-iconv=shared --with-xmlrpc=shared --enable-cgi \
- --with-freetype-dir=shared,/usr --with-mime-magic=shared \
- --enable-discard-path --enable-force-cgi-redirect --disable-cli \
- --with-pgsql=shared --with-pdo-pgsql=shared --with-pic
+ ./configure --build=${CHOST:-i486-alpine-linux-uclibc} \
+ --prefix=/usr \
+ --sysconfdir=/etc/php \
+ --with-layout=GNU \
+ --with-config-file-path=/etc/php \
+ --with-config-file-scan-dir=/etc/php/conf.d \
+ --enable-inline-optimization \
+ --disable-debug \
+ --disable-rpath \
+ --disable-static \
+ --enable-shared \
+ --mandir=/usr/share/man \
+ --with-openssl=shared \
+ --with-zlib=shared \
+ --enable-bcmath=shared \
+ --with-bz2=shared \
+ --enable-calendar=shared \
+ --with-curl=shared \
+ --enable-exif=shared \
+ --enable-ftp=shared \
+ --with-gd=shared \
+ --with-jpeg-dir=shared,/usr \
+ --with-png-dir=shared,/usr \
+ --enable-gd-native-ttf \
+ --enable-mbstring=shared \
+ --with-mcrypt=shared \
+ --with-mysql=shared \
+ --with-mysql-sock=/tmp/mysql.sock \
+ --with-mysql=shared \
+ --with-mysqli=shared \
+ --with-pear=/usr/share/pear \
+ --enable-pdo=shared \
+ --with-pdo-mysql=shared \
+ --with-pdo-sqlite=shared,/usr \
+ --enable-fastcgi \
+ --with-sqlite=shared \
+ --enable-sqlite-utf8 \
+ --enable-shmop=shared \
+ --enable-soap=shared \
+ --enable-sysvmsg=shared \
+ --enable-sysvsem=shared \
+ --enable-sysvshm=shared \
+ --enable-zip=shared \
+ --enable-posix=shared \
+ --enable-sockets=shared \
+ --enable-xml \
+ --with-ttf=shared \
+ --enable-session=shared \
+ --with-regex=php \
+ --with-pcre-regex=/usr \
+ --enable-mbstring=all \
+ --enable-mbregex \
+ --enable-json=shared \
+ --with-iconv=shared \
+ --with-xmlrpc=shared \
+ --enable-cgi \
+ --with-freetype-dir=shared,/usr \
+ --with-mime-magic=shared \
+ --enable-discard-path \
+ --enable-force-cgi-redirect \
+ --disable-cli \
+ --with-pgsql=shared \
+ --with-pdo-pgsql=shared \
+ --with-pic
make || return 1
make -j1 INSTALL_ROOT="$pkgdir" install || return 1
@@ -62,163 +101,38 @@ _mv_mod() {
rmdir "$pkgdir/$d" 2>/dev/null
return 0
}
-
-
-bcmath() {
- depends="uclibc $pkgname"
- _mv_mod bcmath
-}
-
-bz2() {
- depends="uclibc $pkgname"
- _mv_mod bz2
-}
-
-calendar() {
- depends="uclibc $pkgname"
- _mv_mod calendar
-}
-
-curl() {
- depends="uclibc $pkgname curl"
- _mv_mod curl
-}
-
-exif() {
- depends="uclibc $pkgname"
- _mv_mod exif
-}
-
-ftp() {
- depends="uclibc $pkgname openssl"
- _mv_mod ftp
-}
-
-gd() {
- depends="uclibc $pkgname freetype libpng libjpeg zlib"
- _mv_mod gd
-}
-
-iconv() {
- depends="uclibc $pkgname libiconv"
- _mv_mod iconv
-}
-json() {
- depends="uclibc $pkgname"
- _mv_mod json
-}
-
-mcrypt() {
- depends="uclibc $pkgname libmcrypt"
- _mv_mod mcrypt
-}
-
-mime_magic() {
- depends="uclibc $pkgname"
- _mv_mod mime_magic
-}
-
-
-mysql() {
- depends="uclibc $pkgname libmysqlclient"
- _mv_mod mysql
-}
-
-mysqli() {
- depends="uclibc $pkgname libmysqlclient zlib openssl"
- _mv_mod mysqli
-}
-
-openssl() {
- depends="uclibc $pkgname openssl"
- _mv_mod openssl
-}
-
-pdo() {
- depends="uclibc $pkgname"
- _mv_mod pdo
-}
-
-pdo_mysql() {
- depends="uclibc $pkgname libmysqlclient zlib openssl"
- _mv_mod pdo_mysql
-}
-
-pdo_sqlite() {
- depends="uclibc $pkgname sqlite"
- _mv_mod pdo_sqlite
-}
-
-posix() {
- depends="uclibc $pkgname"
- _mv_mod posix
-}
-
-session() {
- depends="uclibc $pkgname"
- _mv_mod session
-}
-
-shmop() {
- depends="uclibc $pkgname"
- _mv_mod shmop
-}
-
-soap() {
- depends="uclibc $pkgname libxml2 zlib"
- _mv_mod soap
-}
-
-sockets() {
- depends="uclibc $pkgname"
- _mv_mod sockets
-}
-
-sqlite() {
- depends="uclibc $pkgname"
- _mv_mod sqlite
-}
-
-sysvmsg() {
- depends="uclibc $pkgname"
- _mv_mod sysvmsg
-}
-
-sysvsem() {
- depends="uclibc $pkgname"
- _mv_mod sysvsem
-}
-
-sysvshm() {
- depends="uclibc $pkgname"
- _mv_mod sysvshm
-}
-
-xmlrpc() {
- depends="uclibc $pkgname libiconv libxml2 zlib"
- _mv_mod xmlrpc
-}
-
-zip() {
- depends="uclibc $pkgname zlib"
- _mv_mod zip
-}
-
-zlib() {
- depends="uclibc $pkgname zlib"
- _mv_mod zlib
-}
-
-postgresql() {
- depends="uclibc $pkgname postgresql"
- _mv_mod pgsql
-}
-
-pdo_pgsql() {
- depends="uclibc $pkgname postgresql"
- _mv_mod pdo_pgsql
-}
+bcmath() { _mv_mod bcmath; }
+bz2() { _mv_mod bz2; }
+calendar() { _mv_mod calendar; }
+curl() { _mv_mod curl; }
+exif() { _mv_mod exif; }
+ftp() { _mv_mod ftp; }
+gd() { _mv_mod gd; }
+iconv() { _mv_mod iconv; }
+json() { _mv_mod json; }
+mcrypt() { _mv_mod mcrypt; }
+mime_magic() { _mv_mod mime_magic; }
+mysql() { _mv_mod mysql; }
+mysqli() { _mv_mod mysqli; }
+openssl() { _mv_mod openssl; }
+pdo() { _mv_mod pdo; }
+pdo_mysql() { _mv_mod pdo_mysql; }
+pdo_sqlite() { _mv_mod pdo_sqlite; }
+posix() { _mv_mod posix; }
+session() { _mv_mod session; }
+shmop() { _mv_mod shmop; }
+soap() { _mv_mod soap; }
+sockets() { _mv_mod sockets; }
+sqlite() { _mv_mod sqlite; }
+sysvmsg() { _mv_mod sysvmsg; }
+sysvsem() { _mv_mod sysvsem; }
+sysvshm() { _mv_mod sysvshm; }
+xmlrpc() { _mv_mod xmlrpc; }
+zip() { _mv_mod zip; }
+zlib() { _mv_mod zlib; }
+postgresql() { _mv_mod pgsql; }
+pdo_pgsql() { _mv_mod pdo_pgsql; }
# devleoper package
dev() {
@@ -227,4 +141,4 @@ dev() {
mv "$pkgdir"/usr/lib/php/build "$subpkgdir"/usr/lib/php/
}
-md5sums="280d6cda7f72a4fc6de42fda21ac2db7 php-5.2.9.tar.bz2"
+md5sums="15c7b5a87f57332d6fc683528e28247b php-5.2.10.tar.bz2"