summaryrefslogtreecommitdiffstats
path: root/extra/pth/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-02-09 16:00:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-02-09 16:00:00 +0000
commit389b51631f484b404964c5197023f237ecebdc93 (patch)
tree235ae677bd32deb76bfe2b6cafec6f5654c301c1 /extra/pth/APKBUILD
parent1025f99a8e12e8510db9e0d1fde2c882eeef709e (diff)
extra/pth: new aport
The GNU Portable Threads http://www.gnu.org/software/pth
Diffstat (limited to 'extra/pth/APKBUILD')
-rw-r--r--extra/pth/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/extra/pth/APKBUILD b/extra/pth/APKBUILD
new file mode 100644
index 00000000000..ce5cc5e126e
--- /dev/null
+++ b/extra/pth/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=pth
+pkgver=2.0.7
+pkgrel=0
+pkgdesc="The GNU Portable Threads."
+url="http://www.gnu.org/software/pth"
+license="LGPL-2.1"
+depends="uclibc"
+subpackages="$pkgname-dev $pkgname-doc"
+source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
+ pth-2.0.5-parallelfix.patch
+ pth-2.0.6-ldflags.patch
+ pth-2.0.6-sigstack.patch
+ "
+
+build () {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ for i in ../*.patch; do
+ msg "Applying $i..."
+ patch -p1 < $i || return 1
+ done
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/share/man
+
+ make || return 1
+ make -j1 DESTDIR="$pkgdir" install
+}
+md5sums="9cb4a25331a4c4db866a31cbe507c793 pth-2.0.7.tar.gz
+7bbd4f3328807c740c86db94e93e48ad pth-2.0.5-parallelfix.patch
+942fa4be28117756cd579937b257b9cc pth-2.0.6-ldflags.patch
+04e43157d758a3dc7925c35e6dd1e39c pth-2.0.6-sigstack.patch"