summaryrefslogtreecommitdiffstats
path: root/extra/slang/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-10 21:37:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-10 21:37:32 +0000
commit99345d507e9ad5110cbca3581d7093b7744d3743 (patch)
treea7828b206e2c22520ed8c659977dbd8b2fccbfdd /extra/slang/APKBUILD
parent77e3db5934ab750a13066681785eca814368dddc (diff)
extra/slang: new aport
S-Lang is a powerful interpreted language http://www.s-lang.org/
Diffstat (limited to 'extra/slang/APKBUILD')
-rw-r--r--extra/slang/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/extra/slang/APKBUILD b/extra/slang/APKBUILD
new file mode 100644
index 00000000000..c1fe9620003
--- /dev/null
+++ b/extra/slang/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=slang
+pkgver=2.1.4
+pkgrel=0
+pkgdesc="S-Lang is a powerful interpreted language"
+url="http://www.s-lang.org/"
+license="GPL"
+subpackages="$pkgname-dev $pkgname-doc"
+depends="uclibc pcre"
+makedepends="pcre-dev"
+source="ftp://ftp.fu-berlin.de/pub/unix/misc/$pkgname/v2.1/$pkgname-$pkgver.tar.gz
+ slang-2.1.3-uclibc.patch
+ "
+
+build () {
+ cd "$srcdir"/$pkgname-$pkgver
+ for i in ../*.patch; do
+ msg "Applying $i..."
+ patch -p1 < $i || return 1
+ done
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc || return 1
+ make || return 1
+ make install-all DESTDIR="$pkgdir" || return 1
+}
+md5sums="3516f593bc04975844f26137c18275d2 slang-2.1.4.tar.gz
+56ca82f415578994b6050e769b6b7bc9 slang-2.1.3-uclibc.patch"