summaryrefslogtreecommitdiffstats
path: root/extra
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-12 20:32:40 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-12 20:32:40 +0000
commit8dbf2b7f4542321ddedce40d0897904401611b88 (patch)
treeb35c1f1cd626f21bc300e46804f75bd33eb769da /extra
parentf44e81160a21aea22c6a8271128e89e3738588dd (diff)
extra/lighttpd: upgrade to 1.4.22, new style init.d
Diffstat (limited to 'extra')
-rw-r--r--extra/lighttpd/APKBUILD16
-rw-r--r--extra/lighttpd/lighttpd.install14
-rw-r--r--extra/lighttpd/lighttpd.post-install4
-rw-r--r--extra/lighttpd/lighttpd.pre-install4
4 files changed, 17 insertions, 21 deletions
diff --git a/extra/lighttpd/APKBUILD b/extra/lighttpd/APKBUILD
index 29db9b695e1..94b5360691a 100644
--- a/extra/lighttpd/APKBUILD
+++ b/extra/lighttpd/APKBUILD
@@ -1,16 +1,17 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lighttpd
-pkgver=1.4.20
-pkgrel=2
+pkgver=1.4.22
+pkgrel=0
pkgdesc="a secure, fast, compliant and very flexible web-server"
url="http://www.lighttpd.net/"
license="custom"
-install="$pkgname.install"
-depends="pcre openssl zlib bzip2 lua"
+install="$pkgname.pre-install $pkgname.post-install"
+depends="pcre openssl zlib lua"
makedepends="flex pcre-dev openssl-dev zlib-dev bzip2-dev lua-dev pkgconfig"
source="http://www.$pkgname.net/download/$pkgname-$pkgver.tar.bz2
$pkgname.initd
$pkgname.confd
- $pkgname.install
+ $install
$pkgname.logrotate
spawn-fcgi.confd
spawn-fcgi.initd
@@ -66,10 +67,11 @@ build() {
install -m644 "$srcdir"/$i "$pkgdir"/etc/lighttpd/$i
done
}
-md5sums="ed6ee0bb714f393219a32768d86984d8 lighttpd-1.4.20.tar.bz2
+md5sums="ed4ca3897eadf419c893b03fee53c982 lighttpd-1.4.22.tar.bz2
6910842e8ba496e8aa984ab30a46eb72 lighttpd.initd
0dede109282bfe685bdec6b35f0e4b6b lighttpd.confd
-9b1aa3c58f50afee7c03b414c28de6f6 lighttpd.install
+e250fe505d07733e920348bea0909c29 lighttpd.pre-install
+6e0e81296d854887e11bc4f8d6f998d7 lighttpd.post-install
ad091c9157134890499f26d170352c9f lighttpd.logrotate
1d925aed297ec4541fb230dd19e11bc1 spawn-fcgi.confd
78bc6ceac57ecaa47abf4d5df857fe57 spawn-fcgi.initd
diff --git a/extra/lighttpd/lighttpd.install b/extra/lighttpd/lighttpd.install
deleted file mode 100644
index 63235f3cc3d..00000000000
--- a/extra/lighttpd/lighttpd.install
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/sh
-
-
-case $1 in
- pre_install)
- adduser -H -h /var/www/localhost/htdocs -s /bin/false -D \
- lighttpd 2>/dev/null
- ;;
- post_install)
- chown lighttpd:lighttpd /var/*/lighttpd
- ;;
-esac
-
-exit 0
diff --git a/extra/lighttpd/lighttpd.post-install b/extra/lighttpd/lighttpd.post-install
new file mode 100644
index 00000000000..5b116a6375e
--- /dev/null
+++ b/extra/lighttpd/lighttpd.post-install
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+chown lighttpd:lighttpd /var/*/lighttpd
+exit 0
diff --git a/extra/lighttpd/lighttpd.pre-install b/extra/lighttpd/lighttpd.pre-install
new file mode 100644
index 00000000000..4682680d6b6
--- /dev/null
+++ b/extra/lighttpd/lighttpd.pre-install
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+adduser -H -h /var/www/localhost/htdocs -s /bin/false -D lighttpd 2>/dev/null
+exit 0