summaryrefslogtreecommitdiffstats
path: root/extra
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-05-28 09:10:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-05-28 09:10:35 +0000
commit3dced00678c95c0330228f4987d9f2b23b4856a7 (patch)
tree6de9313b325a6ac72d5198356b4c91df6b54d04d /extra
parent9088f350abed6419b704c869c8c15e39151bb0b3 (diff)
extra/libvorbis: new aport
Vorbis codec library http://www.xiph.org/ogg/vorbis/
Diffstat (limited to 'extra')
-rw-r--r--extra/libvorbis/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/extra/libvorbis/APKBUILD b/extra/libvorbis/APKBUILD
new file mode 100644
index 00000000000..c4c0713435c
--- /dev/null
+++ b/extra/libvorbis/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libvorbis
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="Vorbis codec library"
+url="http://www.xiph.org/ogg/vorbis/"
+license="custom"
+subpackages="$pkgname-dev $pkgname-doc"
+depends="libogg uclibc"
+makedepends="libogg-dev g++"
+#source="http://people.xiph.org/~giles/2008/$pkgname-$pkgver.tar.gz"
+source="http://downloads.xiph.org/releases/vorbis/libvorbis-1.2.0.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-static || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+}
+md5sums="478646358c49f34aedcce58948793619 libvorbis-1.2.0.tar.gz"