aboutsummaryrefslogtreecommitdiffstats
path: root/main/abiword/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-12 20:40:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-12 20:40:33 +0000
commit27bfa3b740264709e5a6429eec1f68346b64b33b (patch)
tree3b694b91d2e46667b61a1c29932e292ffb318e1f /main/abiword/APKBUILD
parent6647b1d632bb5ee6a3f0bfb9af32fa7d0b074f2b (diff)
main/abiword: build plugins
Diffstat (limited to 'main/abiword/APKBUILD')
-rw-r--r--main/abiword/APKBUILD27
1 files changed, 24 insertions, 3 deletions
diff --git a/main/abiword/APKBUILD b/main/abiword/APKBUILD
index eb33e1f6cf8..3ecdf6aa649 100644
--- a/main/abiword/APKBUILD
+++ b/main/abiword/APKBUILD
@@ -1,18 +1,22 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=abiword
pkgver=2.8.4
-pkgrel=0
+pkgrel=1
pkgdesc="A fully-featured word processor"
url="http://www.abisource.com"
license="GPL"
makedepends="pkgconfig libglade-dev libgsf-dev enchant-dev fribidi-dev wv-dev
- popt-dev jpeg-dev librsvg-dev bzip2-dev"
-subpackages="$pkgname-dev"
+ popt-dev jpeg-dev librsvg-dev bzip2-dev goffice-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-plugin-goffice:goffice
+ $pkgname-plugin-opendocument:opendocument"
source="http://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz"
build() {
cd "$srcdir"/$pkgname-$pkgver
./configure --prefix=/usr \
+ --enable-shared \
+ --disable-static \
+ --enable-plugins="opendocument goffice" \
|| return 1
make || return 1
}
@@ -21,4 +25,21 @@ package() {
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
}
+
+_plugin() {
+ local plugin="$1"
+ pkgdesc="$2"
+ local dir="usr/lib/abiword-${pkgver%.*}/plugins"
+ mkdir -p "$subpkgdir"/$dir
+ mv "$pkgdir"/$dir/$plugin.so "$subpkgdir"/$dir/
+}
+
+goffice() {
+ _plugin goffice "GOffice interaction plugin for AbiWord"
+}
+
+opendocument() {
+ _plugin opendocument "OpenDocument support plugin for AbiWord"
+}
+
md5sums="f782ecb8e07d07ec179f7a143353cc29 abiword-2.8.4.tar.gz"